summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2018-03-31 16:01:05 -0400
committerArun Isaac <arunisaac@systemreboot.net>2018-04-20 02:09:10 +0530
commit652741cf28210ebdc3eaab18e8aa243f44310ba8 (patch)
treed65c40c6b6e43d35c3af7394ccbb60aaaef07067 /gnu/packages/emacs.scm
parent1848cdfb7d8ce9fb78ffc9f6771689ff9ff7e333 (diff)
gnu: emacs-deferred: Enable tests.
* gnu/packages/emacs.scm (emacs-deferred)[arguments]: Add fix-makefile phase. Set #:test-command, and enable tests. [native-inputs]: Add emacs-ert-expectations, emacs-undercover and ert-runner. Signed-off-by: Arun Isaac <arunisaac@systemreboot.net>
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm19
1 files changed, 18 insertions, 1 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 5f7107ea7e..1638b9a91b 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -2487,7 +2487,24 @@ framework for Emacs Lisp to be used with @code{ert}.")
"0xy9zb6wwkgwhcxdnslqk52bq3z24chgk6prqi4ks0qcf2bwyh5h"))
(file-name (string-append name "-" version))))
(build-system emacs-build-system)
- ;; FIXME: Would need 'el-expectations' to actually run tests.
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'fix-makefile
+ (lambda _
+ (substitute* "Makefile"
+ (("\\$\\(CASK\\) exec ") ""))
+ #t)))
+ #:tests? #t
+ ;; FIXME: Normally we'd run the "test" target but for some reason the
+ ;; test-deferred target fails when run in the Guix build environment
+ ;; with the error: (file-error "Searching for program" "No such file or
+ ;; directory" "/bin/sh").
+ #:test-command '("make" "test-concurrent" "test-concurrent-compiled")))
+ (native-inputs
+ `(("emacs-ert-expectations" ,emacs-ert-expectations)
+ ("emacs-undercover" ,emacs-undercover)
+ ("ert-runner" ,ert-runner)))
(synopsis "Simple asynchronous functions for Emacs Lisp")
(description
"The @code{deferred.el} library provides support for asynchronous tasks.