summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-03-20 19:08:29 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-04-16 17:02:34 +0300
commit93aba854dbc559e863d1127a30cdb60eadaa113b (patch)
treed2e1ba7aa90a3ba2e68e95c104dc914641dfcbae /gnu/packages/emacs.scm
parent4d089b5e56420c05a21d138c4c5832cf7ba6e98a (diff)
gnu: Add emacs-closql.
* gnu/packages/emacs.scm (emacs-closql): New public variable.
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index f9da1007e3..ee3fe145fb 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -7793,3 +7793,29 @@ including numbers, strings, symbols, lists, vectors, and closures. EmacSQL
has no concept of @code{TEXT} values; it's all just Lisp objects. The Lisp
object @code{nil} corresponds 1:1 with @code{NULL} in the database.")
(license license:gpl3+)))
+
+(define-public emacs-closql
+ (package
+ (name "emacs-closql")
+ (version "0.5.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/emacscollective/closql/archive/"
+ "v" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0wa6r0kgbb7f19039p5f3di4dvrvxfgpd8bkam94fca7jvzj536c"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-emacsql" ,emacs-emacsql)))
+ (home-page "https://github.com/emacscollective/closql")
+ (synopsis "Store EIEIO objects using EmacSQL")
+ (description
+ "This package allows to store uniform EIEIO objects in an EmacSQL
+database. SQLite is used as backend. This library imposes some restrictions
+on what kind of objects can be stored; it isn't intended to store arbitrary
+objects. All objects have to share a common superclass and subclasses cannot
+add any additional instance slots.")
+ (license license:gpl3)))