summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2018-09-12 15:45:38 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2018-09-12 19:34:17 +0200
commitb002809f848d81dfc4640635d98d8bac3af62cee (patch)
tree333e234f7db78bf460481d7e24c1f6cae19ca14a /gnu/packages/emacs.scm
parent320105eadb7d9b26d818edfea5f17e53a19286a1 (diff)
gnu: Add emacs-blimp.
* gnu/packages/emacs.scm (emacs-blimp): New variable.
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 10d0e63c84..12e5823a9e 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -11905,3 +11905,29 @@ command that downloads the page, isolates the “readable” content with
displays it in an Org-mode buffer. Another command does all of that but
inserts it as an Org entry instead of displaying it in a new buffer.")
(license license:gpl3+)))
+
+(define-public emacs-blimp
+ (let ((commit "e420763d6d18b5d1be552cdbc47f91418343db03"))
+ (package
+ (name "emacs-blimp")
+ (version (git-version "0.0.0" "1" commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/walseb/blimp")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "09wmhpym516b81dfq8smdmysh1fn610dzlyvyl2rkx8600f0fizd"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-eimp" ,emacs-eimp)))
+ (home-page "https://github.com/walseb/blimp")
+ (synopsis "Emacs wrapper around all Imagemagick commands")
+ (description "Blimp (Bustling Image Manipulation Package) is a complete
+wrapper around all Imagemagick commands with descriptions, autocompletion (for
+some commands) and hints displayed in prompt using @command{eimp.el} to
+execute its commands and resize images.")
+ (license license:gpl3+))))