summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-06-18 16:17:32 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-06-20 07:06:58 +0200
commite1918ce486e51477b137f93716b58be779dd870f (patch)
tree310de5f0edd792f1f45e159f57b7870d8e9a9033 /gnu/packages/emacs.scm
parent93dba17c63ab879261bc01b865e8c2c5d5c91d29 (diff)
gnu: Add emacs-iedit.
* gnu/packages/emacs.scm (emacs-iedit): New variable.
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index db00502738..7a66f3177e 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1825,6 +1825,32 @@ called. If there are more, each window will have its first character
highlighted. Pressing that character will switch to that window.")
(license license:gpl3+)))
+(define-public emacs-iedit
+ (package
+ (name "emacs-iedit")
+ (version "0.9.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/victorhge/iedit/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "00v86zllcsivmiibigbr91qij2zdf1lr9db8z8again1sn63wkdj"))))
+ (build-system emacs-build-system)
+ (home-page "http://www.emacswiki.org/emacs/Iedit")
+ (synopsis "Edit multiple regions in the same way simultaneously")
+ (description
+ "This package is an Emacs minor mode and allows you to edit one
+occurrence of some text in a buffer (possibly narrowed) or region, and
+simultaneously have other occurrences edited in the same way.
+
+You can also use Iedit mode as a quick way to temporarily show only the buffer
+lines that match the current text being edited. This gives you the effect of
+a temporary @code{keep-lines} or @code{occur}.")
+ (license license:gpl3+)))
+
(define-public emacs-clojure-mode
(package
(name "emacs-clojure-mode")