summaryrefslogtreecommitdiff
path: root/gnu/packages/emulators.scm
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2023-11-22 16:48:02 +0800
committerMathieu Othacehe <othacehe@gnu.org>2023-11-25 14:47:51 +0100
commit6e4914a037c8b332ab3f1149129c0bd1cea4640b (patch)
treea093f2e9d34e6cda0b7ae139b82c82c11f1c11be /gnu/packages/emulators.scm
parent3350f3be0d4bb9a8f2bff7be15e58803a9f9c19c (diff)
gnu: Add qtrvsim.
* gnu/packages/emulators.scm (qtrvsim): New variable. Change-Id: I8e51184534fa9990c318008513e1e6566a04b10a Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/emulators.scm')
-rw-r--r--gnu/packages/emulators.scm27
1 files changed, 26 insertions, 1 deletions
diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index 0729feb071..138b68bc21 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -20,6 +20,7 @@
;;; Copyright © 2023 c4droid <c4droid@foxmail.com>
;;; Copyright © 2023 Yovan Naumovski <yovan@gorski.stream>
;;; Copyright © 2023 Hendursaga <hendursaga@aol.com>
+;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -111,7 +112,8 @@
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system gnu)
#:use-module (guix build-system meson)
- #:use-module (guix build-system python))
+ #:use-module (guix build-system python)
+ #:use-module (guix build-system qt))
(define-public vice
(package
@@ -2492,6 +2494,29 @@ on a Commodore C64, C128 etc.")
;; zlib license with an (non-)advertising clause.
(license license:zlib)))
+(define-public qtrvsim
+ (package
+ (name "qtrvsim")
+ (version "0.9.5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/cvut/qtrvsim")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1zi39q8ajkzl8d47sacj0dk1a2n5jmfgr29x9iby59v792g7p8ac"))
+ (modules '((guix build utils)))
+ (snippet #~(begin (delete-file-recursively "external/libelf")))))
+ (build-system qt-build-system)
+ (inputs (list libelf qtbase-5))
+ (home-page "https://github.com/cvut/qtrvsim")
+ (synopsis "RISC-V CPU simulator for education purposes")
+ (description "RISC-V CPU simulator for education purposes with pipeline and
+cache visualization. Developed at FEE CTU for computer architecture classes.")
+ (license license:gpl3+)))
+
(define-public cc65
(package
(name "cc65")