summaryrefslogtreecommitdiff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-11-02 10:44:33 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-11-02 12:08:10 +0100
commit3fbe85366f80f5865d4b926798655b436db30823 (patch)
treebcd1a37511ff1f65e62960a5653be0bd1f1a14f7 /gnu/packages/engineering.scm
parent7e75269b8b49579aee6a9e5b2804f6ba257c6039 (diff)
gnu: Add cgns.
* gnu/packages/engineering.scm (cgns): New variable. Co-authored-by: Ontje Luensdorf <Ontje.Luensdorf@dlr.de>
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm32
1 files changed, 31 insertions, 1 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 644c0f8ef9..b2641b1d96 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021, 2022 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Federico Beffa <beffa@fbengineering.ch>
;;; Copyright © 2016, 2018, 2020, 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 David Thompson <davet@gnu.org>
@@ -2585,6 +2585,36 @@ arithmetic operations on fields, entity location functionalities, and
interpolation toolkit.")
(license license:gpl3+)))
+(define-public cgns
+ (package
+ (name "cgns")
+ (version "4.3.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/CGNS/CGNS")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0jig1y7lv9qk1ri2gqws7ffpajmhxnank7gbyna9hfaghsxdlnvd"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:configure-flags
+ '(list "-DCGNS_ENABLE_TESTS=ON"
+ "-DCGNS_ENABLE_FORTRAN=ON")))
+ (inputs (list hdf5 gfortran))
+ (home-page "https://cgns.org/")
+ (synopsis "Read and write computational fluid dynamics analysis data")
+ (description "This package provides software that reads, writes, and
+modifies data in the @dfn{CFD General Notation System} (CGNS) format. The
+format is meant for recording and recovering computer data associated with the
+numerical solution of fluid dynamics equations. The format is a conceptual
+entity established by the documentation; the software is a physical product
+supplied to enable developers to access and produce data recorded in that
+format.")
+ (license license:zlib)))
+
(define-public libarea
(let ((revision "1")
(commit "8f8bac811c10f1f01fda0d742a18591f61dd76ee"))