summaryrefslogtreecommitdiff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2023-08-10 09:23:32 +0200
committerLudovic Courtès <ludo@gnu.org>2023-08-10 09:26:08 +0200
commit66158f535a032137bf0fc88df562defab9cbeb91 (patch)
tree0281df749fb5957b483322890a173b67771c08dd /gnu/packages/engineering.scm
parent8a88b8b0b5924f8ed00a49e79714cb005cffc7cb (diff)
gnu: Do not use (gnu packages commencement) in engineering.scm.
This avoids a circular dependency evidenced by the following commit. * gnu/packages/engineering.scm (freehdl)[inputs]: Resolve 'gcc-toolchain' from here rather than by using (gnu packages commencement).
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 79ba1e4536..9fb9658078 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2015 Federico Beffa <beffa@fbengineering.ch>
;;; Copyright © 2016, 2018, 2020-2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 David Thompson <davet@gnu.org>
-;;; Copyright © 2016, 2017, 2018, 2019, 2021 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2016-2019, 2021, 2023 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016, 2017, 2018 Theodoros Foradis <theodoros@foradis.org>
;;; Copyright © 2017 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2018–2021 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -84,7 +84,6 @@
#:use-module (gnu packages check)
#:use-module (gnu packages cmake)
#:use-module (gnu packages code)
- #:use-module (gnu packages commencement)
#:use-module (gnu packages compression)
#:use-module (gnu packages cpp)
#:use-module (gnu packages curl)
@@ -2242,7 +2241,11 @@ parallel computing platforms. It also supports serial execution.")
#t)))))
(inputs
(list coreutils
- gcc-toolchain
+
+ ;; Lazily resolve the gcc-toolchain to avoid a circular dependency.
+ (module-ref (resolve-interface '(gnu packages commencement))
+ 'gcc-toolchain)
+
guile-2.2
perl
pkg-config