summaryrefslogtreecommitdiff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-06-16 14:31:52 +0200
committerLudovic Courtès <ludo@gnu.org>2016-06-16 14:31:52 +0200
commita7db719f3dc16b6be7aaab45e718798902d82833 (patch)
treea74f4406c4e502b79f7bfd42ff073c80ea08189d /gnu/packages/engineering.scm
parent3d1240aa2561792895795315c7783a28bf4412af (diff)
packages: Disambiguate 'modules' and 'imported-modules' in <origin>.
The two mistakes made here (confusion between 'modules' and 'imported-modules') were canceling each other. * guix/packages.scm (patch-and-repack): Use IMPORTED-MODULES, not MODULES, as the base of the module list passed as #:modules to 'gexp->derivation'. (origin->derivation): Pass IMPORTED-MODULES, not MODULES, as the #:imported-modules argument of 'patch-and-repack'. * gnu/packages/engineering.scm (fastcap)[source]: Add 'imported-modules' field.
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 02b1c4e9eb..7b21c11ad3 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -232,6 +232,7 @@ optimizer; and it can produce photorealistic and design review images.")
(modules '((guix build utils)
(guix build download)
(guix ftp-client)))
+ (imported-modules modules)
(patches (search-patches "fastcap-mulSetup.patch"
"fastcap-mulGlobal.patch"))))
(build-system gnu-build-system)