summaryrefslogtreecommitdiff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-01-12 13:49:46 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-01-12 15:06:43 +0100
commitb09c6b55ad5ca3364e70597b2021ceb8a3db67a3 (patch)
treea2d7a803474b944c840274d14166cd9bb262bce9 /gnu/packages/engineering.scm
parenta0bb98c3220035578a3adef995e0bd36439123d2 (diff)
gnu: harminv: Update to 1.4.1.
* gnu/packages/engineering.scm (harminv): Update to 1.4.1. [source, home-page]: Switch to new host.
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 61abd6058b..24051baf03 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2016, 2017 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016, 2017 Theodoros Foradis <theodoros@foradis.org>
;;; Copyright © 2017 Julien Lepiller <julien@lepiller.eu>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -898,16 +899,16 @@ interface to select the best such procedures to use on a given system.")
(define-public harminv
(package
(name "harminv")
- (version "1.4")
+ (version "1.4.1")
(source (origin
(method url-fetch)
(uri
- (string-append
- "http://ab-initio.mit.edu/harminv/harminv-"
- version ".tar.gz"))
+ (string-append "https://github.com/stevengj/harminv/"
+ "releases/download/v" version "/"
+ name "-" version ".tar.gz"))
(sha256
(base32
- "1pmm8d6fx9ahhnk7w12bfa6zx3afbkg4gkvlvgwhpjxbcrvrp3jk"))))
+ "0w1n4d249vlpda0hi6z1v13qp21vlbp3ykn0m8qg4rd5132j7fg1"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -922,7 +923,7 @@ interface to select the best such procedures to use on a given system.")
`(("fortran" ,gfortran)))
(inputs
`(("lapack" ,lapack)))
- (home-page "http://ab-initio.mit.edu/wiki/index.php/Harminv")
+ (home-page "https://github.com/stevengj/harminv")
(synopsis "Harmonic inversion solver")
(description
"Harminv is a free program (and accompanying library) to solve the problem of