summaryrefslogtreecommitdiff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
authorBruno Victal <mirai@makinata.eu>2023-10-15 18:47:06 +0100
committerLudovic Courtès <ludo@gnu.org>2023-10-21 16:06:00 +0200
commit03b350ab6212506dcd5dd21f8a5d27a6186f1a88 (patch)
tree8fd0b1ffd4efce80d95fab4cfb8e8f5f584690ed /gnu/packages/engineering.scm
parentc8c0db5cb87f66a90e2f6076f9962085befb4f5e (diff)
gnu: poke: Revise package definition.
Rewrite package using G-Expressions. Remove obsolete comments, options and unused dependencies [1]. [1]: GNU poke commit: c17b0fb7d9d0b97398c664c882d6ef1e732bc66a * gnu/packages/engineering.scm (poke)[inputs]: Remove json-c. [arguments]: Use G-Expression. Remove obsolete comments and configure-flags. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm15
1 files changed, 6 insertions, 9 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 80fd9ac141..caaaf2f190 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -3253,18 +3253,15 @@ program that can perform mesh processing tasks in batch mode, without a GUI.")
(delete-file "libpoke/pvm-vm1.c")
(delete-file "libpoke/pvm-vm2.c")))))
(build-system gnu-build-system)
- ;; The GUI, which we elide, requires tcl and tk.
(native-inputs (list bison dejagnu flex libtool pkg-config))
;; FIXME: Enable NBD support by adding `libnbd' (currently unpackaged).
- (inputs (list json-c libgc readline libtextstyle))
+ (inputs (list libgc readline libtextstyle))
(arguments
- ;; To build the GUI, add the `--enable-gui' configure flag.
- ;; To enable the "hyperlink server", add the `--enable-hserver' flag.
- `(#:configure-flags
- '("--enable-mi"
- "--disable-static"
- ;; The emacs files are provided in emacs-poke.
- "--with-lispdir=/tmp/share/emacs")))
+ (list
+ #:configure-flags
+ #~(list "--disable-static"
+ ;; The emacs files are provided in emacs-poke.
+ "--with-lispdir=/tmp/share/emacs")))
(home-page "https://www.gnu.org/software/poke/#documentation")
(synopsis "Editing of arbitrary binary data")
(description "GNU poke is an interactive, extensible editor for binary data.