summaryrefslogtreecommitdiff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2023-03-25 19:23:44 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2023-03-25 19:23:44 +0100
commite0840701ebaefd0fe7cc8608fa88a9ff34c9d528 (patch)
tree046922480d7034e74284ee7af751154131f2468c /gnu/packages/engineering.scm
parent9e0942f7a405b5f2bf8246850298a36ea6de1dc1 (diff)
gnu: volk: Update to 3.0.0.
* gnu/packages/engineering.scm (volk): Update to 3.0.0. [arguments]: Add 'disable-check-lgpl-test' phase. Remove trailing booleans. [license]: Replace gpl3+ by lgpl3+. Add asl2.0.
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm21
1 files changed, 14 insertions, 7 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index ddac57ce8f..ca1beea585 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -1273,7 +1273,7 @@ WiFi signal strength maps. It visualizes them using a Voronoi diagram.")
(define-public volk
(package
(name "volk")
- (version "2.4.1")
+ (version "3.0.0")
(source
(origin
(method git-fetch)
@@ -1283,19 +1283,26 @@ WiFi signal strength maps. It visualizes them using a Voronoi diagram.")
(recursive? #t))) ; for cpu_features git submodule
(file-name (git-file-name name version))
(sha256
- (base32 "1mkqiw0i2fbbsk46zvk8yv5swl7ifhq6y1dlfphq8dsmkvxckqby"))))
+ (base32 "0a59lnjh6hx2bmyn04f8r0ymwss1ss1iih2jwrl9jblkxsw0i3lh"))))
(build-system cmake-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'disable-check-lgpl-test
+ ;; Disable the failing check-lgpl test that is supposed to be run
+ ;; only by upstream developers to check the authors and licenses
+ ;; of contributions in the git history.
+ (lambda _
+ (substitute* "scripts/licensing/count_contrib.sh"
+ (("#!/bin/bash" all)
+ (string-append all "\nexit 0")))))
(add-after 'install 'remove-static-libraries
;; Remove libcpu_features.a (and any others that might appear).
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(lib (string-append out "/lib")))
(for-each delete-file (find-files lib "\\.a$"
- #:fail-on-error? #t))
- #t)))
+ #:fail-on-error? #t)))))
(add-after 'install 'wrap-pythonpath
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -1311,8 +1318,7 @@ WiFi signal strength maps. It visualizes them using a Voronoi diagram.")
(wrap-program file
`("GUIX_PYTHONPATH" ":" prefix (,path))
`("PATH" ":" prefix
- (,(string-append python "/bin:")))))
- #t)))))
+ (,(string-append python "/bin:"))))))))))
(inputs
`(("boost" ,boost)
("python" ,python-wrapper)
@@ -1324,7 +1330,8 @@ WiFi signal strength maps. It visualizes them using a Voronoi diagram.")
with machine-specific optimizations for mathematical functions. It also
provides a machine-independent interface to select the best such procedures to
use on a given system.")
- (license license:gpl3+)))
+ (license (list license:asl2.0 ; cpu_features
+ license:lgpl3+))))
(define-public libredwg
(package