summaryrefslogtreecommitdiff
path: root/gnu/packages/file-systems.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-12-06 09:23:27 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-12-19 12:40:29 +0200
commit3dde5f4df496a2b1415990e138877e71945f557b (patch)
tree2aa75e76847350bfd29603709d59a1f8c3cee180 /gnu/packages/file-systems.scm
parentabd478690ce30a4898bdfc2399e67cbccc8955e1 (diff)
gnu: Add nilfs-utils.
* gnu/packages/file-systems.scm (nilfs-utils): New variable.
Diffstat (limited to 'gnu/packages/file-systems.scm')
-rw-r--r--gnu/packages/file-systems.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index 85454cada3..57a25a0d90 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -752,6 +752,41 @@ transaction log.
from the jfsutils package. It is meant to be used in initrds.")
(license (package-license jfsutils))))
+(define-public nilfs-utils
+ (package
+ (name "nilfs-utils")
+ (version "2.2.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://nilfs.sourceforge.io/download"
+ "/nilfs-utils-" version ".tar.bz2"))
+ (sha256
+ (base32 "15vsayvzr8nc29n939sz9ddq46vpn53rp8h8qv484h88qac3kxjx"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:configure-flags
+ #~(list "--enable-static=no")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'bootstrap 'force-bootstrap
+ (lambda _
+ (delete-file "configure")
+ (substitute* "configure.ac"
+ (("\\[/etc\\]") "[${prefix}/etc]")
+ (("\\[/sbin\\]") "[${prefix}/sbin]")))))))
+ (inputs
+ (list (list util-linux "lib")))
+ (native-inputs (list autoconf automake libtool))
+ (home-page "https://nilfs.sourceforge.io/")
+ (synopsis "Continuous Snapshotting Filesystem")
+ (description
+ "NILFS is a log-structured file system supporting versioning of the entire
+file system and continuous snapshotting, which allows users to even restore
+files mistakenly overwritten or destroyed just a few seconds ago.")
+ (license license:gpl3+)))
+
(define-public disorderfs
(package
(name "disorderfs")