summaryrefslogtreecommitdiff
path: root/gnu/packages/file-systems.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-08-06 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-08-06 02:00:00 +0200
commit90e34d25d5e7c14b7f3293a78f3cdad676c0d035 (patch)
tree32b6fbb0b55f56e50d82a6a44310312edaaf25c0 /gnu/packages/file-systems.scm
parentbf587a2094ef07547181f7e650d60d00357eb232 (diff)
gnu: xfstests: Add inputs.
* gnu/packages/file-systems.scm (xfstests)[arguments]: Search for bc, df, and perl. [inputs]: Add bc.
Diffstat (limited to 'gnu/packages/file-systems.scm')
-rw-r--r--gnu/packages/file-systems.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index e6c6cb2853..90e00d7592 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -44,6 +44,7 @@
#:use-module (gnu packages)
#:use-module (gnu packages acl)
#:use-module (gnu packages admin)
+ #:use-module (gnu packages algebra)
#:use-module (gnu packages attr)
#:use-module (gnu packages autotools)
#:use-module (gnu packages backup)
@@ -1262,8 +1263,10 @@ APFS.")
(dirname (search-input-file inputs file)))
(list "bin/setfacl" ; acl
"bin/attr" ; attr
- "bin/ls" ; coreutils
+ "bin/bc" ; bc
+ "bin/df" ; coreutils
"bin/hostname" ; inetutils
+ "bin/perl" ; perl
"sbin/mkfs.xfs")))))) ; xfsprogs
(add-after 'install 'create-helper
;; Upstream installs only a ‘check’ script that's not in $PATH and
@@ -1322,6 +1325,7 @@ xfstest's \"~a\" command (with any OPTIONs) as documented below.\n\n"
(inputs
(list acl
attr
+ bc
guile-3.0 ; for our xfstests-check helper script
inetutils
`(,util-linux "lib")