summaryrefslogtreecommitdiff
path: root/gnu/packages/finance.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2023-02-19 22:18:19 +0100
committerAndreas Enge <andreas@enge.fr>2023-02-19 22:28:29 +0100
commita0006f4680708b7c22511fc58848c785ab0dd5a4 (patch)
treec27a416056277faa3d4981ef79eea49e58d334eb /gnu/packages/finance.scm
parent8523d79ff5ea6577693e21577dbeab4e8f57481d (diff)
gnu: Add python-u2flib-host.
* gnu/packages/finance.scm (python-u2flib-host): New variable.
Diffstat (limited to 'gnu/packages/finance.scm')
-rw-r--r--gnu/packages/finance.scm23
1 files changed, 22 insertions, 1 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index aa074a92eb..018e067656 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2015, 2016 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2015, 2016, 2023 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2016, 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
@@ -1040,6 +1040,27 @@ settings.")
of Bitcoin BIP-0039.")
(license license:expat)))
+(define-public python-u2flib-host
+ ;; The package is obsolete and superseded by python-fido2, but
+ ;; needed for python-ledgerblue@0.1.44.
+ (package
+ (name "python-u2flib-host")
+ (version "3.0.3")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "python-u2flib-host" version))
+ (sha256
+ (base32
+ "02pwafd5kyjpc310ys0pgnd0adff1laz18naxxwsfrllqafqnrxb"))))
+ (build-system python-build-system)
+ (propagated-inputs (list python-hidapi python-requests))
+ (native-inputs (list python-cryptography))
+ (home-page "https://github.com/Yubico/python-u2flib-host")
+ (synopsis "Python based U2F host library")
+ (description
+ "The package provides library functionality for communicating with a U2F device over USB.")
+ (license license:bsd-2)))
+
(define-public python-ledgerblue
(package
(name "python-ledgerblue")