summaryrefslogtreecommitdiff
path: root/gnu/packages/finance.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2023-05-20 08:02:01 +0000
committerSimon Tournier <zimon.toutoune@gmail.com>2023-05-26 12:46:05 +0200
commitbb6ddc269f776e0c3dc739fb9f49a4c048db3b44 (patch)
treea7df09560d382394bb36f5787fd6a68906a74111 /gnu/packages/finance.scm
parent3299b40b3599371890816b52d65a6a5ada1b1131 (diff)
gnu: Remove bitcoin-abc.
This package (version 0.21.12 from July 2020, which currently doesn't build) is for an outdated version of the Bitcoin Cash protocol. Since November 2020, the bitcoin-abc program has become an implementation of the eCash protocol, which is different from Bitcoin Cash (different consensus model). * gnu/packages/finance.scm (bitcoin-abc): Remove variable. Signed-off-by: Simon Tournier <zimon.toutoune@gmail.com>
Diffstat (limited to 'gnu/packages/finance.scm')
-rw-r--r--gnu/packages/finance.scm66
1 files changed, 0 insertions, 66 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 112246f07c..ccbce898fe 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -1683,72 +1683,6 @@ trezord as a regular user instead of needing to it run as root.")
Trezor wallet.")
(license license:lgpl3+)))
-(define-public bitcoin-abc
- (package
- (name "bitcoin-abc")
- (version "0.21.12")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://download.bitcoinabc.org/"
- version "/src/bitcoin-abc-"
- version ".tar.gz"))
- (sha256
- (base32
- "1amzwy3gpl8ai90dsy7g0z51qq8vxfzbf642wn4bfynb8jmw3kx5"))))
- (build-system cmake-build-system)
- (native-inputs
- (list pkg-config
- python ; for the tests
- util-linux ; provides the hexdump command for tests
- qttools-5))
- (inputs
- (list bdb-5.3
- boost
- jemalloc
- libevent
- miniupnpc
- openssl
- protobuf
- qrencode
- qtbase-5
- zeromq
- zlib))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'configure 'make-qt-deterministic
- (lambda _
- ;; Make Qt deterministic.
- (setenv "QT_RCC_SOURCE_DATE_OVERRIDE" "1")
- #t))
- (add-before 'check 'set-home
- (lambda _
- (setenv "HOME" (getenv "TMPDIR")) ; tests write to $HOME
- #t))
- (add-after 'check 'check-functional
- (lambda _
- (invoke
- "python3" "./test/functional/test_runner.py"
- (string-append "--jobs=" (number->string (parallel-job-count)))
- ;; TODO: find why the abc-miner-fund test fails.
- "--exclude=abc-miner-fund")
- #t)))))
- (home-page "https://www.bitcoinabc.org/")
- (synopsis "Bitcoin ABC peer-to-peer full node for the Bitcoin Cash protocol")
- (description
- "Bitcoin Cash brings sound money to the world, fulfilling the original
-promise of Bitcoin as Peer-to-Peer Electronic Cash. Merchants and users are
-empowered with low fees and reliable confirmations is a digital currency that
-enables instant payments to anyone anywhere in the world. It uses
-peer-to-peer technology to operate without central authority: managing
-transactions and issuing money are carried out collectively by the network.
-As a fork it implemented changes lowering the time between blocks and now
-offers confimations after less than 5 seconds and have significantly lower
-fees that BTC. Bitcoin ABC is the reference implementation of the Bitcoin
-Cash protocol. This package provides the Bitcoin Cash command line client and
-a client based on Qt. This is a fork of Bitcoin Core.")
- (license license:expat)))
-
(define-public libofx
(package
(name "libofx")