summaryrefslogtreecommitdiff
path: root/gnu/packages/finance.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2023-02-19 22:28:51 +0100
committerAndreas Enge <andreas@enge.fr>2023-02-19 22:28:51 +0100
commit4d6607a363ea95f84c42b38cce2d3599926155a2 (patch)
treefff3b1f2709a52e8bd1097abaa96af59ca95ca29 /gnu/packages/finance.scm
parenta0006f4680708b7c22511fc58848c785ab0dd5a4 (diff)
gnu: python-ledgerblue: Update to 0.1.44.
* gnu/packages/finance.scm (python-ledgerblue): Update to 0.1.44. Adapt propagated inputs.
Diffstat (limited to 'gnu/packages/finance.scm')
-rw-r--r--gnu/packages/finance.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 018e067656..7b8c1a8c03 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -118,6 +118,7 @@
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages qt)
#:use-module (gnu packages readline)
+ #:use-module (gnu packages security-token)
#:use-module (gnu packages sphinx)
#:use-module (gnu packages tex)
#:use-module (gnu packages texinfo)
@@ -1064,14 +1065,14 @@ of Bitcoin BIP-0039.")
(define-public python-ledgerblue
(package
(name "python-ledgerblue")
- (version "0.1.16")
+ (version "0.1.44")
(source
(origin
(method url-fetch)
(uri (pypi-uri "ledgerblue" version))
(sha256
(base32
- "010mghaqh1cmz3a0ifc3f40mmyplilwlw7kpha2mzyrrff46p9gb"))))
+ "0nbfa5i9ww7jsfc8cgy0r229pq2a1vj4xvn8mz0nxl7mx1wykqm4"))))
(build-system python-build-system)
(propagated-inputs
(list python-ecpy
@@ -1079,7 +1080,10 @@ of Bitcoin BIP-0039.")
python-hidapi
python-pillow
python-protobuf
- python-pycrypto))
+ python-pycryptodomex
+ python-pyscard
+ python-u2flib-host
+ python-websocket-client))
(home-page "https://github.com/LedgerHQ/blue-loader-python")
(synopsis "Python library to communicate with Ledger Blue/Nano S")
(description "@code{ledgerblue} is a Python library to communicate with