summaryrefslogtreecommitdiff
path: root/gnu/packages/firmware.scm
diff options
context:
space:
mode:
authorJean-Pierre De Jesus DIAZ <jean@foundationdevices.com>2023-11-28 12:35:01 +0100
committerEfraim Flashner <efraim@flashner.co.il>2023-12-11 13:37:21 +0200
commit30d25ee201e0ae69e55494b14f9a08a0c917030b (patch)
treea3ca26b20e9ffc00eee02d867bce51a966ac1729 /gnu/packages/firmware.scm
parenta9a51b0dca2b228ce334bf36db77af015d3b1285 (diff)
gnu: make-ergodox-firmware: Use AVR target.
* gnu/packages/firmware.scm (make-ergodox-firmware/implementation): [arguments]: Add avr as target. [native-inputs]: Remove make-avr-toolchain. Change-Id: I4345a55d5dbd436d524de4886969b3332c6288a9 Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/firmware.scm')
-rw-r--r--gnu/packages/firmware.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/firmware.scm b/gnu/packages/firmware.scm
index 294bbea184..58253b93a7 100644
--- a/gnu/packages/firmware.scm
+++ b/gnu/packages/firmware.scm
@@ -1256,6 +1256,7 @@ OVERRIDE.H, to also override the corresponding layout include file."
(arguments
(list
#:tests? #f ;no test suite
+ #:target "avr"
#:make-flags
#~(list (string-append "LAYOUT=" #$layout)
;; Simplify the output directory name.
@@ -1281,7 +1282,7 @@ OVERRIDE.H, to also override the corresponding layout include file."
(install-file "firmware.hex" #$output)
(install-file "firmware.eep" #$output)
(install-file "firmware--layout.html" #$output)))))))
- (native-inputs (list (make-avr-toolchain) python))
+ (native-inputs (list python))
(home-page "https://www.ergodox.io")
(synopsis "Firmware for the ErgoDox keyboard")
(description (format #f "This package contains the original firmware for