summaryrefslogtreecommitdiff
path: root/gnu/packages/firmware.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-04-28 18:52:36 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-05-27 10:26:23 +0300
commite6eadcb136cfe350fa4ef69805ed2857bcb34d5a (patch)
tree3b6dd8f30a2b4dcee25892e3bfab3d877701b5ae /gnu/packages/firmware.scm
parent16e52098d13352d73daf7406807e2506246a7795 (diff)
gnu: edk2-tools: Enable submodules.
* gnu/packages/firmware.scm (edk2-tools)[source]: Checkout submodules. [arguments]: Don't disable building brotli or xz compression. Change-Id: I8b318373e38767e1a309e9e385f1626429bfbb20
Diffstat (limited to 'gnu/packages/firmware.scm')
-rw-r--r--gnu/packages/firmware.scm15
1 files changed, 4 insertions, 11 deletions
diff --git a/gnu/packages/firmware.scm b/gnu/packages/firmware.scm
index 7e0b75f728..ed79e989c1 100644
--- a/gnu/packages/firmware.scm
+++ b/gnu/packages/firmware.scm
@@ -833,11 +833,13 @@ after an operating system boots.")
(method git-fetch)
(uri (git-reference
(url "https://github.com/tianocore/edk2")
- (commit (string-append "edk2-stable" version))))
+ (commit (string-append "edk2-stable" version))
+ ;; EDK2 makes extensive use of submodules.
+ (recursive? #t)))
(file-name (git-file-name name version))
(sha256
(base32
- "1x0h89cz3ihihcp4n93bw708q9r3icprb8cjsrrfcgq10clavdzx"))))
+ "0y7jfpijgi099znhzjklnsczn0k0vm1d1qznq9x2a2sa0glydsin"))))
(build-system gnu-build-system)
(arguments
(list #:make-flags
@@ -849,15 +851,6 @@ after an operating system boots.")
(add-after 'unpack 'change-directory
(lambda _
(chdir "BaseTools")))
- (add-after 'change-directory 'disable-some-tools
- (lambda _
- ;; Disable building brotli and xz, since we package them
- ;; separately, and it would require fetching submodules.
- (substitute* "Source/C/GNUmakefile"
- (("^[[:blank:]]+BrotliCompress[[:blank:]]+\\\\")
- "\\")
- (("^[[:blank:]]+LzmaCompress[[:blank:]]+\\\\")
- "\\"))))
(replace 'build
(lambda* (#:key (make-flags #~'()) #:allow-other-keys)
;; The default build target also runs tests.