summaryrefslogtreecommitdiff
path: root/gnu/packages/firmware.scm
diff options
context:
space:
mode:
authorJean-Pierre De Jesus DIAZ <jean@foundationdevices.com>2024-01-19 14:54:48 +0100
committerMathieu Othacehe <othacehe@gnu.org>2024-01-22 11:26:57 +0100
commitd264237d55ca5e2c756cc7a44374a7dbca850505 (patch)
tree17303a3745fb8c3d187a9340044c35ac9bd77fa6 /gnu/packages/firmware.scm
parent938f153784e17d055d73f1686b03c1f0642c8340 (diff)
gnu: make-crust-package: Unite firmware and tools.
* gnu/packages/firmware.scm (make-crust-package): Perform union of make-crust-firmware and make-crust-tools. * gnu/packages/firmware.scm (make-crust-firmware): New procedure. Change-Id: I687bb6d53aae9bd60ed988baf9d17e92f31faa7b
Diffstat (limited to 'gnu/packages/firmware.scm')
-rw-r--r--gnu/packages/firmware.scm28
1 files changed, 26 insertions, 2 deletions
diff --git a/gnu/packages/firmware.scm b/gnu/packages/firmware.scm
index 41fe55eb2e..828bc7402a 100644
--- a/gnu/packages/firmware.scm
+++ b/gnu/packages/firmware.scm
@@ -1197,11 +1197,12 @@ such as:
;; Adding debug symbols causes the size to exceed limits.
#~(delete "DEBUG=1" #$flags)))))))
-(define make-crust-package
+(define make-crust-firmware
(mlambda (platform)
(package
(name (string-append "crust-"
- (string-replace-substring platform "_" "-")))
+ (string-replace-substring platform "_" "-")
+ "-firmware"))
(version "0.6")
(source
(origin
@@ -1296,6 +1297,29 @@ AR100.")
(synopsis "Firmware for Allwinner sunxi SoCs (tools)")
(inputs (list firmware)))))
+(define make-crust-package
+ (mlambda (platform)
+ (let* ((firmware (make-crust-firmware platform))
+ (tools (make-crust-tools platform firmware)))
+ (package
+ (inherit firmware)
+ (name (string-append "crust-"
+ (string-replace-substring platform "_" "-")))
+ (source #f)
+ (build-system trivial-build-system)
+ (arguments
+ (list #:modules '((guix build union))
+ #:builder
+ #~(begin
+ (use-modules (ice-9 match)
+ (guix build union))
+
+ (match %build-inputs
+ (((names . directory) ...)
+ (union-build #$output directory))))))
+ (native-inputs '())
+ (inputs (list firmware tools))))))
+
(define-public crust-pinebook
(make-crust-package "pinebook"))