summaryrefslogtreecommitdiff
path: root/gnu/packages/firmware.scm
diff options
context:
space:
mode:
authorJean-Pierre De Jesus DIAZ <jean@foundationdevices.com>2024-01-19 14:54:46 +0100
committerMathieu Othacehe <othacehe@gnu.org>2024-01-22 11:26:56 +0100
commitdde246ed414e2eb1198208a83c129ea6e08949d0 (patch)
tree0af20e32e960d6b7bdc9d0571b3a64783a9e49a4 /gnu/packages/firmware.scm
parentfa0b2cdab3a67299478972dba384ef0768f25897 (diff)
gnu: make-crust-package: Use or1k-elf as target.
* gnu/packages/firmware.scm (make-crust-package): Use or1k-elf as the target. Change-Id: I6c8bf053527f1e12e35402f18cebf8e75557c788
Diffstat (limited to 'gnu/packages/firmware.scm')
-rw-r--r--gnu/packages/firmware.scm20
1 files changed, 7 insertions, 13 deletions
diff --git a/gnu/packages/firmware.scm b/gnu/packages/firmware.scm
index a2e3f785d5..129dd0dfdd 100644
--- a/gnu/packages/firmware.scm
+++ b/gnu/packages/firmware.scm
@@ -1217,13 +1217,13 @@ such as:
(build-system gnu-build-system)
(arguments
(list
+ #:target "or1k-elf"
#:tests? #f ;no test suite
- #:make-flags
- #~(list "CROSS_COMPILE=or1k-elf-"
- "V=1"
- "HOSTAR=ar"
- "HOSTCC=gcc"
- "LEX=flex")
+ #:make-flags #~'("CROSS_COMPILE=or1k-elf-"
+ "V=1"
+ "HOSTAR=ar"
+ "HOSTCC=gcc"
+ "LEX=flex")
#:phases
#~(modify-phases %standard-phases
(delete 'configure)
@@ -1237,13 +1237,7 @@ such as:
(install-file file (string-append #$output
"/libexec")))
(find-files "." "(scp\\.bin|\\.config)$")))))))
- ;; The firmware is cross-compiled using a "bare bones" compiler (no libc).
- ;; Use our own tool chain for that.
- (native-inputs
- (list bison
- (cross-gcc "or1k-elf")
- (cross-binutils "or1k-elf")
- flex))
+ (native-inputs (list bison flex))
(home-page "https://github.com/crust-firmware/crust")
(synopsis "Firmware for Allwinner sunxi SoCs")
(description "Crust improves battery life and thermal performance by