summaryrefslogtreecommitdiff
path: root/gnu/packages/fonts.scm
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2024-02-27 20:28:39 +0800
committerHilton Chain <hako@ultrarare.space>2024-03-17 08:56:36 +0800
commitb6835ef46224dc38000c75cc67604f153280b5ff (patch)
treef8a4f4007a41bfbea9fe846171b12e73b5084516 /gnu/packages/fonts.scm
parentf287fa3e01d577caf9f270828aa79f8fa10e0614 (diff)
gnu: font-google-noto-serif-cjk: Update to 2.002.
* gnu/packages/fonts.scm (font-google-noto-serif-cjk): Update to 2.002. [source]: Switch to variable fonts. [arguments]<#:phases>: Keep only TTCs in "out". Install OTFs into "otf" output. [outputs]: Add "otf". Change-Id: Id22401ce85028951b6044ba418dbad764d581f01
Diffstat (limited to 'gnu/packages/fonts.scm')
-rw-r--r--gnu/packages/fonts.scm18
1 files changed, 15 insertions, 3 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index ebf7160bc0..9ec722c19c 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -1215,17 +1215,29 @@ CJK fonts.")
(define-public font-google-noto-serif-cjk
(package
(name "font-google-noto-serif-cjk")
- (version "2.001")
+ (version "2.002")
(source
(origin
(method url-fetch)
(uri (string-append
"https://github.com/googlefonts/noto-cjk/releases/download/Serif"
- version "/04_NotoSerifCJKOTC.zip"))
+ version "/02_NotoSerifCJK-OTF-VF.zip"))
(file-name (string-append name "-" version ".zip"))
(sha256
- (base32 "1l6r3sz2s0vcyfx6ria7wqcq45zp40gxgg97lh8hpmajhzw301ig"))))
+ (base32 "007jk7rmfapq5zq4ji9d1l5gpp34p98l9ylhiw33q42d66v2g717"))))
(build-system font-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (replace 'install
+ (lambda _
+ (chdir "..") ;For license.
+ (let ((install (assoc-ref %standard-phases 'install)))
+ (with-directory-excursion "Variable/OTC"
+ (install #:outputs `(("out" . ,#$output))))
+ (with-directory-excursion "Variable/OTF"
+ (install #:outputs `(("out" . ,#$output:otf))))))))))
+ (outputs '("out" "otf"))
(home-page "https://www.google.com/get/noto/")
(synopsis "Fonts to cover all languages")
(description "Google Noto Fonts is a family of fonts designed to support