summaryrefslogtreecommitdiff
path: root/gnu/packages/fonts.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-03-21 12:22:31 -0400
committerLeo Famulari <leo@famulari.name>2016-03-21 12:22:31 -0400
commit09ec508a4c14d1bc09622d98f796548d79ab0552 (patch)
tree86cc5a2a67d35ad796bfa33d67869d670d65822e /gnu/packages/fonts.scm
parent2dbed47f5c09347c9af42c5f5bacfccbc1ab4aff (diff)
parent71cafa0472a15f2234e24d3c6d8019ebb38685b0 (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/fonts.scm')
-rw-r--r--gnu/packages/fonts.scm142
1 files changed, 137 insertions, 5 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index c45b01908c..8aa5a0dc33 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014 Joshua Grant <tadni@riseup.net>
;;; Copyright © 2014 Alex Kost <alezost@gmail.com>
@@ -7,6 +7,7 @@
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 Nils Gillmann <niasterisk@grrlz.net>
+;;; Copyright © 2016 Jookia <166291@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -24,6 +25,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages fonts)
+ #:use-module (guix utils)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
@@ -67,14 +69,15 @@ in print. With attention to detail for high resolution rendering.")
(define-public font-ubuntu
(package
(name "font-ubuntu")
- (version "0.80")
+ (version "0.83")
(source (origin
(method url-fetch)
- (uri (string-append "http://font.ubuntu.com/download/ubuntu-font-family-"
- version ".zip"))
+ (uri (string-append
+ "http://font.ubuntu.com/download/ubuntu-font-family-"
+ version ".zip"))
(sha256
(base32
- "0k4f548riq23gmw4zhn30qqkcpaj4g2ab5rbc3lflfxwkc4p0w8h"))))
+ "0hjvq2x758dx0sfwqhzflns0ns035qm7h6ygskbx1svzg517sva5"))))
(build-system trivial-build-system)
(arguments
`(#:modules ((guix build utils))
@@ -235,6 +238,25 @@ package provides the TrueType (TTF) files.")
(license:x11-style
"http://www.gnome.org/fonts/#Final_Bitstream_Vera_Fonts"))))
+(define-public font-cantarell
+ (package
+ (name "font-abattis-cantarell")
+ (version "0.0.24")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/cantarell-fonts/"
+ (version-major+minor version)
+ "/cantarell-fonts-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0r4jnc2x9yncf40lixjb1pqgpq8rzbi2fz33pshlqzjgx2d69bcw"))))
+ (build-system gnu-build-system)
+ (home-page "https://wiki.gnome.org/Projects/CantarellFonts")
+ (synopsis "Cantarell sans-serif typeface")
+ (description "The Cantarell font family is a contemporary Humanist
+sans-serif designed for on-screen reading. It is used by GNOME@tie{}3.")
+ (license license:silofl1.1)))
+
(define-public font-gnu-freefont-ttf
(package
(name "font-gnu-freefont-ttf")
@@ -628,3 +650,113 @@ Unicode's Basic Multilingual Plane. The package also includes
utilities to ease adding new glyphs to the font.")
(home-page "http://unifoundry.com/unifont.html")
(license license:gpl2+)))
+
+(define-public font-google-noto
+ (package
+ (name "font-google-noto")
+ (version "20150929")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://noto-website-2.storage.googleapis.com/"
+ "pkgs/Noto-hinted.zip"))
+ (sha256
+ (base32
+ "13jhpqzhsqhyby8n0ksqg155a3jyaif3nzj9anzbq8s2gn1xjyd9"))))
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder (begin
+ (use-modules (guix build utils)
+ (srfi srfi-26))
+
+ (let ((PATH (string-append (assoc-ref %build-inputs
+ "unzip")
+ "/bin"))
+ (font-dir (string-append %output
+ "/share/fonts/truetype")))
+ (setenv "PATH" PATH)
+ (system* "unzip" (assoc-ref %build-inputs "source"))
+
+ (mkdir-p font-dir)
+ (for-each (lambda (ttf)
+ (copy-file ttf
+ (string-append font-dir "/" ttf)))
+ (find-files "." "\\.ttf$"))
+ (for-each (lambda (otf)
+ (copy-file otf
+ (string-append font-dir "/" otf)))
+ (find-files "." "\\.otf$"))))))
+ (native-inputs `(("unzip" ,unzip)))
+ (home-page "https://www.google.com/get/noto/")
+ (synopsis "Fonts aimed to cover all languages")
+ (description "Googe Noto Fonts is a family of fonts aimed to support all
+languages with a consistent look and aesthetic. It's goal is to have no Unicode
+symbols unable to be displayed properly.")
+ (license license:silofl1.1)))
+
+(define-public font-un
+ (package
+ (name "font-un")
+ (version "1.0.2-080608")
+ ;; The upstream server at kldp.net is serving us broken MIME.
+ ;; See <http://bugs.gnu.org/22908>.
+ (source (origin
+ (method url-fetch)
+ (uri (list
+ (string-append
+ "http://krosos.sdf.org/static/unix/"
+ "un-fonts-core-" version ".tar.gz")
+ ;; XXX: The upstream server at kldp.net
+ (string-append
+ "https://kldp.net/projects/unfonts/download/4695?filename="
+ "un-fonts-core-" version ".tar.gz")))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "13liaz2pmww3aqabm55la5npd08m1skh334ky7qfidxaz5s742iv"))))
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+
+ (let ((tar (string-append (assoc-ref %build-inputs "tar")
+ "/bin/tar"))
+ (PATH (string-append (assoc-ref %build-inputs "gzip")
+ "/bin"))
+ (font-dir (string-append %output "/share/fonts/truetype"))
+ (doc-dir (string-append %output "/share/doc/" ,name)))
+ (setenv "PATH" PATH)
+ (system* tar "xvf" (assoc-ref %build-inputs "source"))
+ (mkdir-p font-dir)
+ (mkdir-p doc-dir)
+ (chdir (string-append "un-fonts"))
+ (for-each (lambda (ttf)
+ (copy-file ttf
+ (string-append font-dir "/"
+ (basename ttf))))
+ (find-files "." "\\.ttf$"))
+ (for-each (lambda (doc)
+ (copy-file doc
+ (string-append doc-dir "/"
+ (basename doc))))
+ '("COPYING" "README"))))))
+ (native-inputs
+ `(("tar" ,tar)
+ ("gzip" ,gzip)))
+ (home-page "https://kldp.net/projects/unfonts/")
+ (synopsis "Collection of Korean fonts")
+ (description
+ "Un-fonts is a family of mainly Korean fonts.
+It contains the following fonts and styles:
+
+@enumerate
+@item UnBatang, UnBatangBold: serif;
+@item UnDotum, UnDotumBold: sans-serif;
+@item UnGraphic, UnGraphicBold: sans-serif style;
+@item UnDinaru, UnDinaruBold, UnDinaruLight;
+@item UnPilgi, UnPilgiBold: script;
+@item UnGungseo: cursive, brush-stroke.
+@end enumerate\n")
+ (license license:gpl2+)))