summaryrefslogtreecommitdiff
path: root/gnu/packages/fontutils.scm
diff options
context:
space:
mode:
authorRikard Nordgren <hrn@posteo.net>2023-06-25 18:46:14 +0000
committerLudovic Courtès <ludo@gnu.org>2023-10-08 23:43:50 +0200
commite1dcf86a357eb617fa3afc32b4032435b9e7291f (patch)
tree63cd2aaac13507ca6c38c499a648526c1b69b48b /gnu/packages/fontutils.scm
parente9c0bb0341b8c7d4d6e24b989d2a7e1d6b2385cf (diff)
gnu: Add python-beziers.
* gnu/packages/fontutils.scm (python-beziers): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/fontutils.scm')
-rw-r--r--gnu/packages/fontutils.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index c50b11b949..abb79711da 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -371,6 +371,37 @@ but also provides many useful font conversion and analysis facilities.
python-ufonormalizer
python-ufoprocessor))))
+(define-public python-beziers
+ (package
+ (name "python-beziers")
+ (version "0.5.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/simoncozens/beziers.py")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1dyr45m15sclbgaz1mrcnw8kny50h09gd45dlpfkgv9qpfxphkg3"))))
+ (build-system python-build-system)
+ (arguments
+ (list #:phases #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-vv")))))))
+ (native-inputs (list python-pytest python-dotmap python-matplotlib))
+ (propagated-inputs (list python-pyclipper))
+ (home-page "https://simoncozens.github.io/beziers.py/index.html")
+ (synopsis "Python bezier manipulation library")
+ (description
+ "Beziers provides a variety of classes for constructing,
+manipulating and drawing Bezier curves and paths. Principally designed for
+font design software, it allows you to join, split, offset, and perform many
+other operations on paths.")
+ (license license:expat)))
+
(define-public python-cffsubr
(package
(name "python-cffsubr")