summaryrefslogtreecommitdiff
path: root/gnu/packages/fontutils.scm
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2016-02-19 12:32:15 +0100
committer宋文武 <iyzsong@gmail.com>2016-02-20 08:41:51 +0800
commit6ef0ec7600313804662ac1588789661dc74880a5 (patch)
tree08786630a35d768f3df616ad9638f1694bd0f81e /gnu/packages/fontutils.scm
parent4e58a402ff9f28686501ab390be93a6866d382f6 (diff)
gnu: Add libotf.
* gnu/packages/fontutils.scm (libotf): New variable.
Diffstat (limited to 'gnu/packages/fontutils.scm')
-rw-r--r--gnu/packages/fontutils.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 7b5b330f06..cf46dbf729 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -259,6 +259,28 @@ resolution.")
(license license:gpl2+)
(home-page "http://potrace.sourceforge.net/")))
+(define-public libotf
+ (package
+ (name "libotf")
+ (version "0.9.13")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://download.savannah.gnu.org/releases/m17n/libotf-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "0239zvfan56w7vrppriwy77fzb10ag9llaz15nsraps2a2x6di3v"))))
+ (build-system gnu-build-system)
+ (propagated-inputs
+ `(("freetype" ,freetype)))
+ (home-page "http://www.nongnu.org/m17n/")
+ (synopsis "Library for handling OpenType Font")
+ (description "This library can read Open Type Layout Tables from an OTF
+file. Currently these tables are supported; head, name, cmap, GDEF, GSUB, and
+GPOS. It can convert a Unicode character sequence to a glyph code sequence by
+using the above tables.")
+ (license license:lgpl2.0+)))
+
(define-public libspiro
(package
(name "libspiro")