summaryrefslogtreecommitdiff
path: root/gnu/packages/fontutils.scm
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2023-06-13 08:35:57 +0200
committerJanneke Nieuwenhuizen <janneke@gnu.org>2023-07-20 10:11:36 +0200
commit72fa5eb020d8d6e5fa89366ffba15e5d285f2445 (patch)
tree429f096bcdf1f50e2b0c8dacab0f571e990cf16e /gnu/packages/fontutils.scm
parentd3a1684c8a092bb729d68a840abea28092dfc587 (diff)
gnu: graphite2: Skip test on the Hurd.
* gnu/packages/fontutils.scm (graphite2)[arguments]: When building natively on the Hurd, replace phase 'check' to set make-flags to skip "awamicmp3" test.
Diffstat (limited to 'gnu/packages/fontutils.scm')
-rw-r--r--gnu/packages/fontutils.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index e5170b5ae3..64b15fbf05 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -17,6 +17,7 @@
;;; Copyright © 2022 Felipe Balbi <balbi@kernel.org>
;;; Copyright © 2023 gemmaro <gemmaro.dev@gmail.com>
;;; Copyright © 2023 John Kehayias <john.kehayias@protonmail.com>
+;;; Copyright © 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1369,6 +1370,25 @@ applications should be.")
(list python python-fonttools-minimal))
(inputs
(list freetype))
+ (arguments
+ (if (system-hurd?)
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ ;; cmake-build-system ignores #:make-flags for make check
+ (lambda* (#:key test-target tests? parallel-tests?
+ #:allow-other-keys)
+ (if tests?
+ (let ((jobs (if parallel-tests?
+ (number->string (parallel-job-count))
+ "1")))
+ (invoke "make"
+ (string-append
+ "ARGS=-j " jobs " --exclude-regex ^awamicmp3$")
+ test-target))
+ (format #t "test suite not run~%"))))))
+ '()))
(synopsis "Reimplementation of the SIL Graphite text processing engine")
(description
"Graphite2 is a reimplementation of the SIL Graphite text processing