summaryrefslogtreecommitdiff
path: root/gnu/packages/fontutils.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-02-13 12:04:51 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-02-13 12:04:51 +0200
commitef35f0046fc8239e1a80a8a3c88e49c1c85c3676 (patch)
treeb25ce16d3e237bd8d6672bc6fda2314c65dc5748 /gnu/packages/fontutils.scm
parent42c1a83a98787ec92afff82df5c140a43cea30f0 (diff)
gnu: freetype: Don't keep a reference to pkg-config.
* gnu/packages/fontutils.scm (freetype)[arguments]: Add an entry in disallowed-references for pkg-config. Add a phase to remove the reference to pkg-config in an installed script.
Diffstat (limited to 'gnu/packages/fontutils.scm')
-rw-r--r--gnu/packages/fontutils.scm13
1 files changed, 11 insertions, 2 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index bdabe2adee..300290a21d 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2013, 2014, 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014, 2016 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2016 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2016, 2017, 2020, 2022 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2020, 2022, 2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Rene Saavedra <rennes@openmailbox.org>
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2017 Nikita <nikita@n0.is>
@@ -97,7 +97,16 @@
(arguments
;; The use of "freetype-config" is deprecated, but other packages still
;; depend on it.
- `(#:configure-flags (list "--enable-freetype-config")))
+ `(#:configure-flags (list "--enable-freetype-config")
+ #:disallowed-references (,pkg-config)
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'remove-reference-to-pkg-config
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (substitute* (string-append out "/bin/freetype-config")
+ (((search-input-file inputs "/bin/pkg-config"))
+ "pkg-config"))))))))
(native-inputs
(list pkg-config))
(propagated-inputs