summaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
authorPetr Hodina <phodina@protonmail.com>2022-08-26 09:58:25 +0200
committerMarius Bakke <marius@gnu.org>2022-11-21 22:01:12 +0100
commit4cb6ef78dc23a352b965e505afeec2c6626737ee (patch)
tree460fd11c8b75bb5eb54f24eb5bc2490ccd044560 /gnu/packages/freedesktop.scm
parent5a6833113b633267197f8a39c8932aab7954681c (diff)
gnu: Add xdg-desktop-portal-kde.
* gnu/packages/freedesktop.scm (xdg-desktop-portal-kde): New variable. Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 9a588b21a6..3a4fee5e20 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -61,6 +61,7 @@
#:use-module (guix build-system perl)
#:use-module (guix build-system python)
#:use-module (guix build-system glib-or-gtk)
+ #:use-module (guix build-system qt)
#:use-module (gnu packages)
#:use-module (gnu packages acl)
#:use-module (gnu packages admin)
@@ -73,6 +74,7 @@
#:use-module (gnu packages cmake)
#:use-module (gnu packages compression)
#:use-module (gnu packages cryptsetup)
+ #:use-module (gnu packages cups)
#:use-module (gnu packages curl)
#:use-module (gnu packages databases)
#:use-module (gnu packages disk)
@@ -2665,6 +2667,42 @@ which uses GTK+ and various pieces of GNOME infrastructure, such as the
interfaces.")
(license license:lgpl2.1+)))
+(define-public xdg-desktop-portal-kde
+ (package
+ (name "xdg-desktop-portal-kde")
+ (version "5.25.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/plasma/" version "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0l3lmwihxyl65y0mkyg3afk1k6gc0ldjw2vg92g7yydbgmn39q7k"))))
+ (build-system qt-build-system)
+ (native-inputs (list extra-cmake-modules pkg-config))
+ (inputs (list cups
+ kcoreaddons
+ kconfig
+ ki18n
+ kdeclarative
+ kio
+ kirigami
+ knotifications
+ plasma-framework
+ plasma-wayland-protocols
+ kwayland
+ kwidgetsaddons
+ kwindowsystem
+ kiconthemes
+ qtdeclarative-5
+ qtwayland-5
+ wayland))
+ (synopsis "Backend implementation for xdg-desktop-portal using Qt/KF5")
+ (description "This package provides a backend implementation
+for xdg-desktop-portal that is using Qt/KF5.")
+ (home-page "https://invent.kde.org/plasma/xdg-desktop-portal-kde")
+ (license license:lgpl2.0+)))
+
(define-public xdg-desktop-portal-wlr
(package
(name "xdg-desktop-portal-wlr")