summaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
authorBruno Victal <mirai@makinata.eu>2023-10-09 21:06:15 +0100
committerLudovic Courtès <ludo@gnu.org>2024-06-17 22:51:37 +0200
commitb609ba8617ecce41334359fadd890e58d243f691 (patch)
tree6f017134cf7487779cf8ff514bc566b1b5e88d88 /gnu/packages/freedesktop.scm
parentc329ba9876b097ff9e2a942bc10b8946314e2313 (diff)
gnu: xdg-utils: Drop docbook workarounds.
* gnu/packages/freedesktop.scm (xdg-utils)[arguments]<#:phases>: Drop locate-catalog-files. [modules]: Properly import gnu-build-system modules. [native-inputs]: Reorder. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Change-Id: I47f00f5901649b6e530a544fee97f41fa66c6572
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm32
1 files changed, 4 insertions, 28 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 84a614dd7f..3cd571f277 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -612,7 +612,8 @@ database is translated at Transifex.")
"1nai806smz3zcb2l5iny4x7li0fak0rzmjg6vlyhdqm8z25b166p"))))
(build-system gnu-build-system)
(native-inputs
- (list docbook-xsl docbook-xml-4.1.2 libxslt w3m-for-tests xmlto))
+ (list docbook-xsl docbook-xml-4.1.2
+ libxslt xmlto w3m-for-tests))
(inputs
(list bash-minimal ;for 'wrap-program'
coreutils
@@ -628,7 +629,8 @@ database is translated at Transifex.")
(list
#:tests? #f ;no check target
#:modules `((srfi srfi-26)
- ,@%gnu-build-system-modules)
+ (guix build gnu-build-system)
+ (guix build utils))
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'patch-hardcoded-paths
@@ -639,32 +641,6 @@ database is translated at Transifex.")
(substitute* "scripts/xdg-open.in"
(("/usr/bin/printf")
(search-input-file inputs "bin/printf")))))
- (add-before 'build 'locate-catalog-files
- (lambda* (#:key native-inputs inputs #:allow-other-keys)
- (let* ((native (or native-inputs inputs))
- (xmldoc (search-input-directory native
- "xml/dtd/docbook"))
- (xsldoc (search-input-directory
- native
- (string-append "xml/xsl/docbook-xsl-"
- #$(package-version
- (this-package-native-input
- "docbook-xsl"))))))
- (for-each (lambda (file)
- (substitute* file
- (("http://.*/docbookx\\.dtd")
- (string-append xmldoc "/docbookx.dtd"))))
- (find-files "scripts/desc" "\\.xml$"))
- (substitute* "scripts/Makefile"
- ;; Apparently `xmlto' does not bother to looks up the stylesheets
- ;; specified in the XML, unlike the above substitition. Instead it
- ;; uses a hard-coded URL. Work around it here, but if this is
- ;; common perhaps we should hardcode this path in xmlto itself.
- (("\\$\\(XMLTO\\) man")
- (string-append "$(XMLTO) -x " xsldoc
- "/manpages/docbook.xsl man")))
- (setenv "STYLESHEET"
- (string-append xsldoc "/html/docbook.xsl")))))
(add-after 'install 'wrap-executables
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((dependencies '("awk" "grep" "hostname" "ls" "mimeopen"