summaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
authorBruno Victal <mirai@makinata.eu>2023-10-09 21:06:48 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-10 21:11:04 -0400
commitd662e247763794b747c00b9d2f95ce731392cfe2 (patch)
treeab7338ccca93ba5b4573367f561cba450e2529c7 /gnu/packages/freedesktop.scm
parent6b35c7a995e01587c3f478ec66beaf12944c71aa (diff)
gnu: Remove unneeded libxml2 from native-inputs. (libxslt)
XML_CATALOG_FILES is already set within libxslt so it's unnecessary to include libxml2 for the same effect. * gnu/packages/freedesktop.scm (wayland): Remove obsolete comment. (farstream, elogind, packagekit, accountsservice, plymouth)[native-inputs]: Remove libxml2. * gnu/packages/benchmark.scm (sysbench)[native-inputs]: Ditto. * gnu/packages/cluster.scm (drbd-utils)[native-inputs]: Ditto. * gnu/packages/glib.scm (dbus)[native-inputs]: Ditto. * gnu/packages/gnome.scm (gnome-keyring, glade3, dconf, libsecret, colord) (upower, gnome-settings-daemon)[native-inputs]: Ditto. * gnu/packages/gtk.scm (gdk-pixbuf)[native-inputs]: Ditto. * gnu/packages/linux.scm (eudev)[native-inputs]: Ditto. * gnu/packages/networking.scm (iputils)[native-inputs]: Ditto. * gnu/packages/ocr.scm (tesseract-ocr)[native-inputs]: Ditto. * gnu/packages/polkit.scm (polkit)[native-inputs]: Ditto. * gnu/packages/samba.scm (samba/pinned)[native-inputs]: Ditto. * gnu/packages/sssd.scm (adcli)[native-inputs]: Ditto. * gnu/packages/terminals.scm (kmscon)[native-inputs]: Ditto. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm7
1 files changed, 1 insertions, 6 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 7f290b89e3..cf8959d34c 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -275,7 +275,6 @@ application-centers for distributions.")
gobject-introspection
gtk-doc/stable
libtool
- libxml2 ;for XML_CATALOG_FILES
libxslt
perl
pkg-config
@@ -748,7 +747,6 @@ the freedesktop.org XDG Base Directory specification.")
docbook-xsl
gettext-minimal
gperf
- libxml2 ;for XML_CATALOG_FILES
m4
pkg-config
python
@@ -979,7 +977,6 @@ with localed. This package is extracted from the broader systemd package.")
gettext-minimal
`(,glib "bin")
gobject-introspection
- libxml2 ;for XML_CATALOG_FILES
libxslt
pkg-config
python-wrapper
@@ -1185,7 +1182,7 @@ Python.")
(list pkg-config-for-build
this-package) ;for wayland-scanner
'())))
- (inputs (list expat libxml2)) ;for XML_CATALOG_FILES
+ (inputs (list expat libxml2))
(propagated-inputs (list libffi))
(home-page "https://wayland.freedesktop.org/")
(synopsis "Core Wayland window system code and protocol")
@@ -1629,7 +1626,6 @@ message bus.")
`(,glib "bin") ; for gdbus-codegen, etc.
gobject-introspection
gtk-doc
- libxml2 ;for XML_CATALOG_FILES
libxslt
pkg-config
vala
@@ -2495,7 +2491,6 @@ Its features include:
(native-inputs
(list gettext-minimal
pkg-config
- libxml2 ;for XML_CATALOG_FILES
libxslt
docbook-xsl
docbook-xml))