summaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
authorPetr Hodina <phodina@protonmail.com>2022-10-02 15:08:52 +0200
committerMarius Bakke <marius@gnu.org>2022-11-21 22:01:09 +0100
commite7a7e434375a4b6150323f6f6c8f6e8f6642b1f9 (patch)
tree56e0291939bc14d5a7c5740b4ae57ea87b08214f /gnu/packages/freedesktop.scm
parentc1c576ad7c6f4535d1f47870dda14b36590d93a5 (diff)
gnu: Add maliit-keyboard.
* gnu/pacakges/freedesktop.scm (maliit-keyboard): New variable. Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index a965f4242d..61d959e03f 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -424,6 +424,47 @@ inappropriate content.")
method framework.")
(license license:lgpl2.1+)))
+(define-public maliit-keyboard
+ (package
+ (name "maliit-keyboard")
+ (version "2.3.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/maliit/keyboard")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0g89lckl4wzwamc89hs8871fbiyrsjwzk5b6ic4vhc4d1clyqzaw"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:tests? #f
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'install 'install-schemas
+ (lambda* (#:key source outputs #:allow-other-keys)
+ (with-directory-excursion (string-append #$output
+ "/share/glib-2.0/schemas")
+ (invoke "glib-compile-schemas" ".")))))))
+ (native-inputs (list extra-cmake-modules pkg-config gettext-minimal
+ `(,glib "bin")))
+ (inputs (list hunspell
+ glib
+ libchewing
+ libpinyin
+ maliit-framework
+ presage
+ qtbase-5
+ qtdeclarative-5
+ qtmultimedia-5
+ qtquickcontrols2-5))
+ (home-page "https://github.com/maliit/keyboard")
+ (synopsis "Maliit Keyboard")
+ (description
+ "This package provides virtual keyboard for Wayland and X11
+display servers. It supports many different languages and emoji.")
+ (license license:gpl3+)))
+
(define-public xdg-utils
(package
(name "xdg-utils")