summaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-10-08 10:09:07 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-10-08 10:10:06 +0200
commit9e1c255b35a16c408fbd408c6690af6c30ea9180 (patch)
treedaa29b22aebb5cdae0e2800323da94c6ca6787bd /gnu/packages/freedesktop.scm
parent4678f77b499e6a2bb7afff0b9a2d38aa19642bb7 (diff)
gnu: weston: Use G-expression.
* gnu/packages/freedesktop.scm (weston)[arguments]: Use gexp to remove references to %outputs and %build-inputs.
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm33
1 files changed, 17 insertions, 16 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 109b7664d1..ab37f04bef 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -1209,22 +1209,23 @@ protocol either in Wayland core, or some other protocol in wayland-protocols.")
(propagated-inputs
(list libxkbcommon pixman wayland))
(arguments
- `(#:configure-flags
- (list
- ;; Otherwise, the RUNPATH will lack the final path component.
- (string-append "-Dc_link_args=-Wl,-rpath="
- (assoc-ref %outputs "out") "/lib:"
- (assoc-ref %outputs "out") "/lib/weston:"
- (assoc-ref %outputs "out") "/lib/libweston-"
- ,(version-major (package-version this-package)))
- "-Dbackend-default=auto"
- "-Dsystemd=false"
- (string-append "-Dxwayland-path="
- (assoc-ref %build-inputs "xorg-server-xwayland")
- "/bin/Xwayland"))
- #:parallel-tests? #f ; Parallel tests cause failures.
- #:phases
- (modify-phases %standard-phases
+ (list
+ #:configure-flags
+ #~(list
+ ;; Otherwise, the RUNPATH will lack the final path component.
+ (string-append "-Dc_link_args=-Wl,-rpath="
+ #$output "/lib:"
+ #$output "/lib/weston:"
+ #$output "/lib/libweston-"
+ #$(version-major (package-version this-package)))
+ "-Dbackend-default=auto"
+ "-Dsystemd=false"
+ (string-append "-Dxwayland-path="
+ #$(this-package-input "xorg-server-xwayland")
+ "/bin/Xwayland"))
+ #:parallel-tests? #f ; Parallel tests cause failures.
+ #:phases
+ '(modify-phases %standard-phases
(add-before 'configure 'use-elogind
(lambda _
;; Use elogind instead of systemd