summaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2023-03-02 10:37:28 +0000
committerChristopher Baines <mail@cbaines.net>2023-03-02 10:55:08 +0000
commit7df09ee0ab3e7962ef27859ce87e06a323059284 (patch)
treed81334f742ddcb9a1ee63961ca6410922980af1c /gnu/packages/freedesktop.scm
parent2ac51ec99b58b50c08ba719a8c7e9dba0330b065 (diff)
parentaf95f2d8f98eb2c8c64954bb2fd0b70838899174 (diff)
Merge remote-tracking branch 'savannah/master' into core-updates
Conflicts: gnu/local.mk gnu/packages/autotools.scm gnu/packages/cmake.scm gnu/packages/gnuzilla.scm gnu/packages/haskell.scm gnu/packages/pdf.scm gnu/packages/python-xyz.scm gnu/packages/samba.scm gnu/packages/tex.scm gnu/packages/tls.scm gnu/packages/wxwidgets.scm
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index f58d53e7ac..9ba53cd044 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -134,7 +134,7 @@
(define-public appstream
(package
(name "appstream")
- (version "0.15.5")
+ (version "0.15.6")
(source
(origin
(method url-fetch)
@@ -143,7 +143,7 @@
"appstream/releases/"
"AppStream-" version ".tar.xz"))
(sha256
- (base32 "1hh41r82a2p7anyadfsp9lmylrrj1a6gknx2g4w6ha97riifs5fb"))))
+ (base32 "03pirmc5r4izl6mzff879g7pk1nxq03kgpr2yvnnqnlb6r0ckmi3"))))
(build-system meson-build-system)
(arguments
(list
@@ -835,7 +835,8 @@ of a the system to know what users are logged in, and where.")
(build-system meson-build-system)
(native-inputs
(list pkg-config python gperf))
- (inputs
+ (propagated-inputs
+ ;; Propagated because of pkg-config
(list libcap))
(synopsis "The sd-bus library, extracted from systemd")
(description "Some projects rely on the sd-bus library for DBus support.
@@ -1531,7 +1532,7 @@ formats.")
(list pkg-config))
(inputs
(list eudev))
- (home-page "http://0pointer.de/blog/projects/being-smart.html")
+ (home-page "https://0pointer.de/blog/projects/being-smart.html")
(synopsis "ATA S.M.A.R.T. reading and parsing library")
(description
"This library supports a subset of the ATA S.M.A.R.T. (Self-Monitoring,
@@ -2659,7 +2660,7 @@ compatible with the well-known scripts of the same name.")
(define-public xdg-desktop-portal
(package
(name "xdg-desktop-portal")
- (version "1.14.4")
+ (version "1.14.6")
(source (origin
(method url-fetch)
(uri (string-append
@@ -2667,7 +2668,7 @@ compatible with the well-known scripts of the same name.")
version "/xdg-desktop-portal-" version ".tar.xz"))
(sha256
(base32
- "0wqc9x3k7lf3mig53i4rjazi0xi8bcykwaaw7r7prvnscnd1k405"))))
+ "1q0djpnwlrqm0h0alyh1r6dlkqdrr7mj5hiam4mqzxqa5jbqkrgj"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)