summaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-06-27 15:53:21 +0200
committerMarius Bakke <marius@gnu.org>2020-06-27 20:08:23 +0200
commitcd533cb4976da24bb87d2dffd8a65f72734f7117 (patch)
treeacbce3d2c9312edda2c4192b00fe4d9d0eb178f2 /gnu/packages/freedesktop.scm
parent28d3f49e355bacff4889b357458ab903ae861da9 (diff)
gnu: exempi: Delete the static library.
* gnu/packages/freedesktop.scm (exempi)[arguments]: Add phase to delete libexempi.a.
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 1f17485b8d..23cd1aabf9 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -859,7 +859,18 @@ XEv.")
(build-system gnu-build-system)
(arguments
`(#:configure-flags (list (string-append "--with-boost="
- (assoc-ref %build-inputs "boost")))))
+ (assoc-ref %build-inputs "boost")))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'remove-static-library
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; XXX: Some tests fail to build with --disable-static due to
+ ;; symbols not being visible in the shared library:
+ ;; <https://gitlab.freedesktop.org/libopenraw/exempi/-/issues/17>.
+ ;; Simply delete the static library instead to save ~4.3 MiB.
+ (delete-file (string-append (assoc-ref outputs "out")
+ "/lib/libexempi.a"))
+ #t)))))
(native-inputs
`(("boost" ,boost))) ; tests
(inputs