summaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
authorKei Kebreau <kei@openmailbox.org>2016-08-30 17:40:17 -0400
committerKei Kebreau <kei@openmailbox.org>2016-09-01 11:24:51 -0400
commit261b3da532300475f2e1af997db8e327c93def7f (patch)
tree7eac50bdfc357f3005f6733bafd800259ae9c191 /gnu/packages/freedesktop.scm
parent71d4676069f13155594ef13f5ccc4583a4cf77c2 (diff)
gnu: Add telepathy-mission-control.
* gnu/packages/freedesktop.scm (telepathy-mission-control): New variable.
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index ac98769bd1..2032dce66a 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -647,6 +647,37 @@ package enables usage of IRC channels and private messages in Telepathy instant
messaging clients such as Empathy, GNOME Shell or KDE Telepathy.")
(license (list license:lgpl2.1 license:lgpl2.1+))))
+(define-public telepathy-mission-control
+ (package
+ (name "telepathy-mission-control")
+ (version "5.16.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://telepathy.freedesktop.org/releases/"
+ name "/" name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "0zcbx69k0d3p2pjh3g7sa3q2zkd5xchxkqsmlfn3fwxaz0pmsmvi"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("glib:bin" ,glib "bin") ; for glib-compile-schemas, etc.
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("dconf" ,dconf)
+ ("gtk-doc" ,gtk-doc)
+ ("libgnome-keyring" ,libgnome-keyring)
+ ("python" ,python-2)
+ ("xsltproc" ,libxslt)))
+ (propagated-inputs
+ `(("telepathy-glib" ,telepathy-glib)))
+ (home-page "https://telepathy.freedesktop.org/wiki/Components/Mission_Control/")
+ (synopsis "Telepathy real-time communication framework management daemon")
+ (description
+ "Telepathy Mission Control 5 is an account manager and channel dispatcher
+for the Telepathy framework, allowing user interfaces and other clients to
+share connections to real-time communication services without conflicting.")
+ (license license:lgpl2.1)))
+
(define-public colord-gtk
(package
(name "colord-gtk")