summaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-07-29 10:23:53 +0200
committerLudovic Courtès <ludo@gnu.org>2016-07-29 17:40:24 +0200
commitc38fb02e9b6f14171cbc839f99990e0b44a947a9 (patch)
tree2a76fc21344d35cbf062a4724de1f1ff57c8810a /gnu/packages/freedesktop.scm
parent66e076642c0a5f1293288b2c77f739b001f5d190 (diff)
gnu: Add libinput-minimal.
* gnu/packages/freedesktop.scm (libinput-minimal): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 458331d703..0262d0a1ed 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -106,6 +106,16 @@ freedesktop.org project.")
other applications that need to directly deal with input devices.")
(license license:x11)))
+(define-public libinput-minimal
+ (package (inherit libinput)
+ (name "libinput-minimal")
+ (inputs
+ `(("libevdev" ,libevdev)
+ ("mtdev" ,mtdev)))
+ (arguments
+ `(#:configure-flags
+ '("--disable-libwacom")))))
+
(define-public libxdg-basedir
(package
(name "libxdg-basedir")