summaryrefslogtreecommitdiff
path: root/gnu/packages/ftp.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-09-10 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-09-10 02:00:00 +0200
commit4c4ff2e1f077786d85c47ceeec10340a864e17f1 (patch)
treea7a9be8c91c9ba770a646689a72ddee5e5910b19 /gnu/packages/ftp.scm
parent39db6489e8e7a6dc0e37c1d23345753a5cdf5cab (diff)
gnu: vsftpd: Fix build with recent OpenSSL.
* gnu/packages/ftp.scm (vsftpd)[arguments]: Add "-Wno-deprecated-declarations" to CFLAGS. Reported by helioscultist in #guix.
Diffstat (limited to 'gnu/packages/ftp.scm')
-rw-r--r--gnu/packages/ftp.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/ftp.scm b/gnu/packages/ftp.scm
index 5edbc412ea..80e346d658 100644
--- a/gnu/packages/ftp.scm
+++ b/gnu/packages/ftp.scm
@@ -266,6 +266,9 @@ directory comparison and more.")
(arguments
`(#:make-flags
(list (string-append "CC=" ,(cc-for-target))
+ ;; Work around, e.g., “ssl.c:149:7: error: ‘EC_KEY_free’ is
+ ;; deprecated: Since OpenSSL 3.0 [-Werror=deprecated-declarations]”
+ "CFLAGS=-Wno-deprecated-declarations"
;; vsf_findlibs.sh looks only for hard-coded {/usr,}/lib file names
;; that will never exist on Guix. Manage libraries ourselves.
"LDFLAGS=-lcap -lpam"