summaryrefslogtreecommitdiff
path: root/gnu/packages/ftp.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-04-15 23:01:53 +0200
committerLudovic Courtès <ludo@gnu.org>2014-04-15 23:55:15 +0200
commit158adb661175ed77694a56902a2e347a8192500f (patch)
treeaf8a392b34d3f03f1732aa6e122c84c0e783aaf4 /gnu/packages/ftp.scm
parent2b42718b34a7084418a780d553b67ce377171d41 (diff)
gnu: Add lftp.
* gnu/packages/ftp.scm: New file. * gnu-system.am (GNU_SYSTEM_MODULES): Add it.
Diffstat (limited to 'gnu/packages/ftp.scm')
-rw-r--r--gnu/packages/ftp.scm56
1 files changed, 56 insertions, 0 deletions
diff --git a/gnu/packages/ftp.scm b/gnu/packages/ftp.scm
new file mode 100644
index 0000000000..96af2bf649
--- /dev/null
+++ b/gnu/packages/ftp.scm
@@ -0,0 +1,56 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages ftp)
+ #:use-module ((guix licenses) #:select (gpl3+))
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu)
+ #:use-module (gnu packages ncurses)
+ #:use-module (gnu packages readline)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages gnutls)
+ #:use-module (gnu packages compression))
+
+(define-public lftp
+ (package
+ (name "lftp")
+ (version "4.4.15")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://lftp.yar.ru/ftp/lftp-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "0s38vc2ij869dwx3i1c7sk96mqv0hknf3cqf86av59rqnix0px3m"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("zlib" ,zlib)
+ ("readline" ,readline)
+ ("gnutls" ,gnutls)))
+ (home-page "http://lftp.yar.ru/")
+ (synopsis "Command-line file transfer program")
+ (description
+ "LFTP is a sophisticated FTP/HTTP client, and a file transfer program
+supporting a number of network protocols. Like Bash, it has job control and
+uses the Readline library for input. It has bookmarks, a built-in mirror
+command, and can transfer several files in parallel. It was designed with
+reliability in mind.")
+ (license gpl3+)))