summaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-08-14 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-08-14 02:00:56 +0200
commit5456a144c70ec11723b7400d9c47ea3abdcf8eed (patch)
tree06a612d38289ec721195fbff4f55dc6f87532769 /gnu/packages/game-development.scm
parent466021fb90d88ef9cecbb8cd491e7991bae1b6e5 (diff)
gnu: ioquake3: Deduplicate make flags.
* gnu/packages/game-development.scm (ioquake3)[arguments]: Honour #:make-flags in the 'install phase.
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 774564ed2a..0a78ec6ad2 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -2178,12 +2178,12 @@ of the others")
#~(modify-phases %standard-phases
(delete 'configure) ; no configure-script
(replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (invoke "make" "copyfiles" "CC=gcc"
- "USE_INTERNAL_LIBS=0"
- (string-append "COPYDIR="
- (assoc-ref outputs "out")
- "/bin")))))))
+ (lambda* (#:key make-flags outputs #:allow-other-keys)
+ (apply invoke "make" "copyfiles"
+ (string-append "COPYDIR="
+ (assoc-ref outputs "out")
+ "/bin")
+ make-flags))))))
(home-page "https://ioquake3.org/")
(synopsis "FPS game engine based on Quake 3")
(description "ioquake3 is a free software first person shooter engine