summaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorJesse Gibbons <jgibbons2357@gmail.com>2023-07-29 07:37:06 -0600
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-07-30 07:51:44 +0200
commit6a2b5c66bf57bd1bbc6300e1f99e16e65f2478e8 (patch)
tree7dd8f72bd2a7d75da075f419832ba3c4bc84805f /gnu/packages/game-development.scm
parent03fd290423c61af4873a4eacaf8a50ca9a2ff9ac (diff)
gnu: renpy: Fix image reference paths.
The current approach to fixing paths is flawed in that it affects too many of them. See <https://issues.guix.gnu.org/issue/64925#4> for a detailed report of the current defect. gnu/packages/game-development.scm: (renpy)[drop-game-from-paths]: Only drop game from paths that also have “gui7”. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 127cbac127..f4b1a1e1e3 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1458,7 +1458,7 @@ are only used to bootstrap it.")
(lambda _
(substitute* (list "launcher/game/gui7.rpy"
"launcher/game/gui7/images.py")
- ((", \"game\",") ","))
+ ((", \"game\", \"gui7\",") ", \"gui7\","))
#t))
(add-before 'build 'start-xserver
(lambda* (#:key inputs native-inputs #:allow-other-keys)