summaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorAdam Faiz <adam.faiz@disroot.org>2023-12-25 08:16:08 +0800
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-12-31 12:31:17 +0100
commitc3d8a7242a179f96f583d6c66300e838ea19fc7d (patch)
tree0e0c848ef65398e562e46317b5f916f02d856827 /gnu/packages/game-development.scm
parent1185b14a29992200434854d219ad2de2f9f13a4f (diff)
gnu: Add inform.
* gnu/packages/game-development.scm (inform): New variable. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index f2139b315f..dc6de4a801 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -2583,6 +2583,33 @@ added. The permanent goal is to create a Quake 3 distribution upon which
people base their games, ports to new platforms, and other projects.")
(license license:gpl2))))
+(define-public inform
+ ;; The latest release does not yet have a build system.
+ ;; This commit is the earliest to have one.
+ (let ((commit "20cbfff96015938809d0e3da6cd0d83b76d27f14")
+ (revision "0"))
+ (package
+ (name "inform")
+ (version (git-version "6.41" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://jxself.org/git/inform.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "19z8pgrj1s2irany5s6xxwsm3bdnri1as46fdi16zdp4aah523jy"))))
+ (build-system gnu-build-system)
+ (native-inputs (list autoconf automake))
+ (synopsis "The Inform 6 compiler")
+ (description
+ "Inform 6 is a programming language designed for interactive fiction.
+This version of the compiler has been modified slightly to work better when the
+Inform standard library is in a non-standard location.")
+ (home-page "https://jxself.org/git/inform.git")
+ (license license:gpl3+))))
+
(define-public instead
(package
(name "instead")