summaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-07-16 02:00:02 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-16 02:00:08 +0200
commitd23ced7cc1d59af4bf8cac28e332ca29bc7b93e1 (patch)
tree4488baa79ce83aba282955e832039945abb49949 /gnu/packages/game-development.scm
parent7967da108860f453180afb2446a5758c04b577d0 (diff)
gnu: mygui: Update to 3.4.2.
* gnu/packages/game-development.scm (mygui): Update to 3.4.2. (mygui-gl)[inputs]: Add libglvnd, and a union of sdl2 and sdl2-image.
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 9d1a429662..af467dbb38 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1713,7 +1713,7 @@ robust and compatible with many systems and operating systems.")
(define-public mygui
(package
(name "mygui")
- (version "3.4.1")
+ (version "3.4.2")
(source
(origin
(method git-fetch)
@@ -1722,8 +1722,7 @@ robust and compatible with many systems and operating systems.")
(commit (string-append "MyGUI" version))))
(file-name (git-file-name name version))
(sha256
- (base32
- "1gyd4bzm6qqpqw6is065qs5c729gl6rp989bnkygha6q4s371vz6"))))
+ (base32 "0gkfahz118gpqa2906cjb3d4w8g13rv8v3ma7s0ml9l5cci785f8"))))
(build-system cmake-build-system)
(arguments
'(#:tests? #f ; No test target
@@ -1770,7 +1769,10 @@ of use.")
(inputs
(modify-inputs (package-inputs mygui)
(delete "ogre")
- (prepend mesa glu)))
+ (prepend glu
+ libglvnd ; for find_package(… GLX)
+ mesa ; for find_package(… OpenGL …)
+ (sdl-union (list sdl2 sdl2-image)))))
(synopsis "Fast, flexible and simple GUI (OpenGL backend)")))
(define-public openmw