summaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2016-11-07 00:33:16 -0500
committerMark H Weaver <mhw@netris.org>2016-11-07 00:33:16 -0500
commit71e21fb26dceef7a665b3b1c0dec7ebd92d8ec82 (patch)
tree7553a6f9ee2ed7494968e7277897098559eacf23 /gnu/packages/game-development.scm
parent19ac2ba858ebc46db96364809ebfc129be9e4ccf (diff)
parent14ac8e4865206f5cd1278cd962d01ce27890d51f (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm23
1 files changed, 14 insertions, 9 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 693d728464..76c06ecc72 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -69,20 +69,25 @@
(define-public bullet
(package
(name "bullet")
- (version "2.82-r2704")
+ (version "2.85.1")
(source (origin
(method url-fetch)
- (uri (string-append "https://bullet.googlecode.com/files/bullet-"
- version ".tgz"))
+ (uri (string-append "https://github.com/bulletphysics/bullet3/"
+ "archive/" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1lnfksxa9b1slyfcxys313ymsllvbsnxh9np06azkbgpfvmwkr37"))))
+ "0qpd37ws0xlxwy55dg058a5b4yw2jxiz09yyc3lc0frpa05pq5bf"))))
(build-system cmake-build-system)
- (arguments '(#:tests? #f ; no 'test' target
- #:configure-flags (list
- (string-append
- "-DCMAKE_CXX_FLAGS=-fPIC "
- (or (getenv "CXXFLAGS") "")))))
+ (arguments
+ '(#:configure-flags (list (string-append
+ "-DBUILD_SHARED_LIBS=ON "
+ "-DCMAKE_CXX_FLAGS=-fPIC "
+ (or (getenv "CXXFLAGS") "")))))
+ (inputs
+ `(("glu" ,glu)
+ ("libx11" ,libx11)
+ ("mesa" ,mesa)))
(home-page "http://bulletphysics.org/")
(synopsis "3D physics engine library")
(description