summaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2022-08-08 10:15:13 +0800
committer宋文武 <iyzsong@member.fsf.org>2022-08-08 10:34:58 +0800
commitee216d16ef5ea537eaf5508dcffa5d808ab62bb0 (patch)
treeb65908e8842eb59b563563b3bcf6bbe4f24614b5 /gnu/packages/game-development.scm
parenteed987855ced6d1774326cf5b261680727c5d65a (diff)
gnu: tiled: Fix build.
Fixes <https://issues.guix.gnu.org/57048>. * gnu/packages/game-development.scm (tiled)[arguments]: Use 'search-input-file' to locate 'lrelease'.
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 70bd4c0251..090e7f7d12 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -531,8 +531,8 @@ formats such as PNG.")
(substitute* "translations/translations.pro"
(("LRELEASE =.*")
(string-append "LRELEASE = "
- (assoc-ref inputs "qttools-5")
- "/bin/lrelease\n")))
+ (search-input-file inputs "/bin/lrelease")
+ "\n")))
(let ((out (assoc-ref outputs "out")))
(invoke "qmake"
(string-append "PREFIX=" out))))))))