summaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2015-01-19 15:12:52 -0500
committerDavid Thompson <dthompson2@worcester.edu>2015-01-19 15:12:52 -0500
commitb0910aad2ff609ade904bf3806e58b51466c8fd1 (patch)
tree4c2d52637d823b9ea99ecab1af30510e069e4d3d /gnu/packages/game-development.scm
parentc72aed6d8c000efcc4cd3a912b13773e9ed46453 (diff)
gnu: tiled: Move to game-development module.
* gnu/packages/games.scm (tiled): Move from here... * gnu/packages/game-development (tiled): ...to here.
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm43
1 files changed, 40 insertions, 3 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 056b3681a7..338979e821 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -17,11 +17,14 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages game-development)
- #:use-module (guix licenses)
+ #:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system cmake)
- #:use-module (gnu packages))
+ #:use-module (guix build-system gnu)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages qt)
+ #:use-module (gnu packages compression))
(define-public bullet
(package
@@ -45,4 +48,38 @@
(description
"Bullet is a physics engine library usable for collision detection. It
is used in some video games and movies.")
- (license zlib)))
+ (license license:zlib)))
+
+(define-public tiled
+ (package
+ (name "tiled")
+ (version "0.10.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/bjorn/tiled/archive/v"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0p4p3lv4nw11fkfvvyjirb93r2x4w2rrc2w650gl2k57k92jpiij"))))
+ (build-system gnu-build-system)
+ (inputs `(("qt" ,qt)
+ ("zlib" ,zlib)))
+ (arguments
+ '(#:phases
+ (alist-replace
+ 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (system* "qmake"
+ (string-append "PREFIX=" out))))
+ %standard-phases)))
+ (home-page "http://www.mapeditor.org/")
+ (synopsis "Tile map editor")
+ (description
+ "Tiled is a general purpose tile map editor. It is meant to be used for
+editing maps of any tile-based game, be it an RPG, a platformer or a Breakout
+clone.")
+
+ ;; As noted in 'COPYING', part of it is under GPLv2+, while the rest is
+ ;; under BSD-2.
+ (license license:gpl2+)))