summaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2020-06-23 10:12:54 -0400
committerKei Kebreau <kkebreau@posteo.net>2020-06-23 10:23:00 -0400
commit362ae4313ebdb56223a8ed5511437b59f7876c22 (patch)
tree0f1c59a4232e3602f6b39bda7b17b8530e876e70 /gnu/packages/game-development.scm
parent6562a3883f4a6f23e98f4800043397918a1fbafd (diff)
gnu: nml: Update to 0.5.2.
* gnu/packages/game-development.scm (nml): Update to 0.5.2. [source]: Fetch from pypi. [arguments]: Remove 'fix-pillow' phase and disable tests. [home-page]: Update URL.
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm22
1 files changed, 8 insertions, 14 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 9ef92a11f2..7eabf46627 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -313,30 +313,24 @@ provide connectivity for client applications written in any language.")
(define-public nml
(package
(name "nml")
- (version "0.4.5")
+ (version "0.5.2")
(source
(origin
(method url-fetch)
- (uri (string-append "http://bundles.openttdcoop.org/nml/releases/"
- version "/nml-" version ".tar.gz"))
+ (uri (pypi-uri "nml" version))
(sha256
(base32
- "1pmvvm3sgnpngfa7884mqhq3fwdjh9sr0ca07ypnidcg0y341w53"))))
+ "1lwf5sc5qqzrkxfx5wkkj3yh2j2nzh5r599ly5psy8yw92km24hy"))))
(build-system python-build-system)
+ ;; TODO: Fix test that fails with
+ ;; "AttributeError: partially initialized module 'nml.nmlop' has no
+ ;; attribute 'ADD' (most likely due to a circular import)"
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'build 'fix-pillow
- (lambda _
- ;; pillow's version is not in PIL.Image.VERSION anymore
- (substitute* "nml/version_info.py"
- (("from PIL import Image") "import PIL")
- (("Image.VERSION") "PIL.__version__"))
- #t)))))
+ '(#:tests? #f))
(propagated-inputs
`(("python-pillow" ,python-pillow)
("python-ply" ,python-ply)))
- (home-page "https://dev.openttdcoop.org/projects/nml")
+ (home-page "https://github.com/OpenTTD/nml")
(synopsis "NML compiler")
(description
"@dfn{NewGRF Meta Language} (NML) is a python-based compiler, capable of