summaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2016-05-12 18:48:36 -0400
committerMark H Weaver <mhw@netris.org>2016-05-12 18:48:36 -0400
commit207c604637737408a3d4cd9214a9e69ce4b21bb3 (patch)
treec26225dd535e59866677b1dda1d1714b95f417a5 /gnu/packages/game-development.scm
parent11d7d7b5d399f38712eb68ab9a20e5dc0d6ef30e (diff)
parentef06d54a9b9ee4fb5015c78ab94f8df1d3a72f1d (diff)
Merge branch 'gnome-updates'
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm10
1 files changed, 1 insertions, 9 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 86cbb2d41e..bc0051d4c6 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -374,15 +374,7 @@ etc.")
"-DENABLE_UPDATER=0" ; no auto-updates
(string-append "-DFREETYPE_INCLUDE_DIR="
(assoc-ref %build-inputs "freetype")
- "/include/freetype2"))
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-freetype-utils
- (lambda _
- ;; Fix C preprocessor include directive.
- (substitute* '("src/app/util/freetype_utils.cpp")
- (("freetype/") ""))
- #t)))))
+ "/include/freetype2"))))
(native-inputs
`(("pkg-config" ,pkg-config)))
;; TODO: Use a patched Allegro 4 that supports window resizing. This