summaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorKei Yamashita <kei@openmailbox.org>2016-04-12 12:47:26 -0400
committer宋文武 <iyzsong@gmail.com>2016-04-13 14:25:51 +0800
commit966dff3b81bfb46dd824d0c7e21f473fe1e7addd (patch)
tree3b842f4415e85e0e0804607d44566c9389b23280 /gnu/packages/game-development.scm
parent2b8e9d9ed4273d5ea42cc79510b61fe71a398901 (diff)
gnu: Add qqwing.
* gnu/packages/game-development.scm (qqwing): New variable. Signed-off-by: 宋文武 <iyzsong@gmail.com>
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 0a58a7efa5..414af14f28 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2015 Alex Kost <alezost@gmail.com>
;;; Copyright © 2015, 2016 David Thompson <davet@gnu.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016 Kei Yamashita <kei@openmailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -407,3 +408,35 @@ games. In addition to basic pixel editing features, Aseprite can assist in
the creation of animations, tiled graphics, texture atlases, and more.")
(home-page "http://www.aseprite.org/")
(license license:gpl2+)))
+
+(define-public qqwing
+ (package
+ (name "qqwing")
+ (version "1.3.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://qqwing.com/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0bw0papyqjg22z6irf36gs54y8236wa37b6gyn2h1spy65n76lqp"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "https://qqwing.com/")
+ (synopsis "Sudoku puzzle solver and generator")
+ (description
+ "QQWing is a Sudoku puzzle generator and solver.
+It offers the following features:
+@enumerate
+@item Can solve 1000 puzzles in 1 second and generate 1000 puzzles in 25 seconds.
+@item Uses logic. Uses as many solve techniques as possible when solving
+ puzzles rather than guessing.
+@item Rates puzzles. Most generators don't give an indication of the difficulty
+ of a Sudoku puzzle. QQwing does.
+@item Can print solve instructions for any puzzle.
+@item Customizable output style, including a CSV style that is easy to
+ import into a database.
+@end enumerate")
+ (license license:gpl2+)))