summaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2024-01-04 00:03:40 -0500
committerJohn Kehayias <john.kehayias@protonmail.com>2024-01-04 00:03:40 -0500
commitef4e4c9a2ccc1678182fa6e4409fff13c669fd14 (patch)
treed1f097787a69fa3a7089f26ecfed8b5c267883db /gnu/packages/game-development.scm
parent42c448ee6e13d165807d83e8c48941bead4847c1 (diff)
parent7b0863f07a113caef26fea13909bd97d250b629e (diff)
Merge branch 'master' into mesa-updates
Change-Id: I46ca25bea98d25150877421c6d5161752afabb25
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm52
1 files changed, 52 insertions, 0 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index f2139b315f..73f93a9992 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -56,6 +56,7 @@
#:use-module (guix svn-download)
#:use-module (guix utils)
#:use-module (guix build-system cmake)
+ #:use-module (guix build-system copy)
#:use-module (guix build-system gnu)
#:use-module (guix build-system python)
#:use-module (guix build-system scons)
@@ -2583,6 +2584,57 @@ added. The permanent goal is to create a Quake 3 distribution upon which
people base their games, ports to new platforms, and other projects.")
(license license:gpl2))))
+(define-public inform
+ ;; The latest release does not yet have a build system.
+ ;; This commit is the earliest to have one.
+ (let ((commit "20cbfff96015938809d0e3da6cd0d83b76d27f14")
+ (revision "0"))
+ (package
+ (name "inform")
+ (version (git-version "6.41" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://jxself.org/git/inform.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "19z8pgrj1s2irany5s6xxwsm3bdnri1as46fdi16zdp4aah523jy"))))
+ (build-system gnu-build-system)
+ (native-inputs (list autoconf automake))
+ (synopsis "The Inform 6 compiler")
+ (description
+ "Inform 6 is a programming language designed for interactive fiction.
+This version of the compiler has been modified slightly to work better when the
+Inform standard library is in a non-standard location.")
+ (home-page "https://jxself.org/git/inform.git")
+ (license license:gpl3+))))
+
+(define-public informlib
+ (package
+ (name "informlib")
+ (version "6.12.6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://jxself.org/git/informlib.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0fcnw4jjzln402qk097n2s8y24vw1p3mmlmh6k1mbr2zfajjcn5r"))))
+ (build-system copy-build-system)
+ (arguments
+ (list
+ #:install-plan
+ #~'(("." "lib"))))
+ (synopsis "Inform 6 standard library")
+ (description
+ "This package provides the standard library for Inform 6.")
+ (home-page "https://jxself.org/git/informlib.git")
+ (license license:agpl3+)))
+
(define-public instead
(package
(name "instead")