summaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-02-22 00:49:38 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-22 02:49:10 +0100
commit006345c16e11c9175ec8e73b1532e600c53e7b84 (patch)
tree353d0b36ee4ae0a99eb6a03016d6d6cbd2493c4e /gnu/packages/game-development.scm
parente05da20448b1010da8ec8b4a8324d85fe6c5c8bb (diff)
gnu: ois: Update to 1.5.
* gnu/packages/game-development.scm (ois): Update to 1.5. [source]: Use tagged VERSION and GIT-FILE-NAME. [build-system]: Switch to CMAKE-BUILD-SYSTEM. [arguments]: Disable tests. [native-inputs]: Remove them. [inputs]: Replace libxaw with libx11.
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm23
1 files changed, 8 insertions, 15 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index ac01cb3f2f..7f00f7080b 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1005,28 +1005,21 @@ painted with a mouse.")
(define-public ois
(package
(name "ois")
- (version "1.3")
+ (version "1.5")
(source
(origin
- ;; Development has moved to github and there are no recent tarball
- ;; releases.
(method git-fetch)
(uri (git-reference
(url "https://github.com/wgois/OIS.git")
- (commit "bb75ccc1aabc1c547195579963601ff6080ca2f2")))
- (file-name (string-append name "-" version))
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "0w0pamjc3vj0jr718hysrw8x076fq6n9rd6wcb36sn2jd0lqvi98"))))
- (build-system gnu-build-system)
- (native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)
- ("m4" ,m4)
- ("pkg-config" ,pkg-config)))
+ (base32 "0g8krgq5bdx2rw7ig0xva4kqv4x815672i7z6lljp3n8847wmypa"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f)) ; no test suite
(inputs
- `(("libxaw" ,libxaw)))
+ `(("libx11" ,libx11)))
(synopsis "Object Oriented Input System")
(description
"Cross Platform Object Oriented Input Lib System is a cross platform,