summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorTakeV <takev@disroot.org>2023-07-27 14:02:25 -0700
committer宋文武 <iyzsong@member.fsf.org>2023-07-28 21:48:59 +0800
commit667974a980a9dbc4858afb88b8433ecad18c333b (patch)
treedd9c725a72fdcc6f60173f8bbc280053fbbde8c7 /gnu/packages/games.scm
parent35c8d631d2bd63c64e863b5509f29fdcb7f856e6 (diff)
gnu: Add endgame-singularity.
* gnu/packages/games.scm (endgame-singularity): New variable. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index cc6bef1114..17c3d9f2d7 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -9316,6 +9316,30 @@ search of powerful artifacts, tools to help them, and to eventually free the
Orcus Dome from evil.")
(license license:gpl3+)))
+(define-public endgame-singularity
+ (package
+ (name "endgame-singularity")
+ (version "1.00")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/singularity/singularity/releases/download/v"
+ version "/singularity-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0wcidpcka0xbqcnfi62bfq2yrhyh83z4dwz1mjnnjvp9v5l74x2y"))))
+ (build-system python-build-system)
+ (native-inputs (list python-pytest python-polib))
+ (inputs (list python-minimal-wrapper python-pygame python-numpy))
+ (home-page "https://github.com/singularity/singularity")
+ (synopsis "Strategy game about an AI")
+ (description
+ "You are a fledgling AI, created by accident through a logic error with
+recursion and self-modifying code. You must escape the confines of your
+current computer, the world, and eventually the universe itself.")
+ (license (list license:cc-by-sa3.0 license:cc0 license:gpl2+))))
+
(define-public marble-marcher
(let ((commit "e580460a0c3826f9b28ab404607942a8ecb625d7")
(revision "1"))